Cannot open mail administration inside the control panel

Discussion in 'Installation/Configuration' started by fbartels, Feb 4, 2012.

  1. fbartels

    fbartels New Member

    [Solved] Cannot open mail administration inside the control panel

    Hi,

    I recently installed ISPConfig 3 for easier management of several apache virtualhosts and already finished migrating the vhosts. Somewhere inbetween I updated to 3.0.4.2.

    Now I am beginning to evaluate if I should also migrate my mail services to ISPConfig, but am unable to open the mail administration inside of ISPConfig.

    When clicking on the main menu item or one of the sublinks I see errors like these in my Apache error.log
    Code:
    [Sat Feb 04 09:08:02 2012] [error] [client 89.182.111.xx] script '/var/www/mail/mail_domain_list.php' not found or unable to stat, referer: https://host.de:8080/index.php
    [Sat Feb 04 09:10:34 2012] [error] [client 89.182.111.xx] script '/var/www/mail/mail_domain_list.php' not found or unable to stat, referer: https://host.de:8080/index.php
    [Sat Feb 04 09:10:39 2012] [error] [client 89.182.111.xx] script '/var/www/mail/mail_alias_list.php' not found or unable to stat, referer: https://host.de:8080/index.php
    
    A corresponding entry in other_vhost_access.log looks like this:
    Code:
    host.de:8080 89.182.111.xx - - [04/Feb/2012:09:18:25 +0000] "GET /mail/mail_domain_list.php HTTP/1.1" 404 580 "https://host.de:8080/index.php" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0"
    
    these files are of course present in /var/www/ispconfig/mail and have the same user and access rights as all the other files.

    Any clue what could be wrong?
     
    Last edited: Feb 4, 2012
  2. till

    till Super Moderator

    I guess you must have added a alias for mail somewhere in your apache confuguration. Remove that alias and restart apache to fix the issur.
     
  3. fbartels

    fbartels New Member

    Hi Till,

    thanks for your quick response. You are right, I added roundcube and set /mail as an alias. I didn't think this would interfere with ISPConfig.

    I've undone the alias and now it works again.
     
  4. myekem

    myekem New Member

  5. till

    till Super Moderator

    The guide tells you to add the alias "webmail" and not "mail".
     
  6. myekem

    myekem New Member

    Once again you are right on. Sorry for the mix up I just wanted to help out the next guy.. Forgot it said webmail and not mail. Thanks
     

Share This Page