Cannot login via new FTP user account

Discussion in 'Installation/Configuration' started by clammy77, Jun 15, 2010.

  1. clammy77

    clammy77 New Member

    Hi,

    1. I recreated a client using my admin account.
    2. I logged into the client account and created a website.
    3. I created a ftp user for the website.

    I tried logging in, but I just keep getting this:
    COMMAND:> [6/15/2010 3:17:20 PM] PASS *****
    [6/15/2010 3:17:30 PM] 530 Login authentication failed

    I was able to get connected but the password is wrong. I've made sure my password is right, and I've also typed in the client's name + the ftp user name.

    What am I doing wrong? Please help!

    Edward
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. clammy77

    clammy77 New Member

    This is what I got:


    Jun 15 16:33:15 starz pure-ftpd: (?@203.70.38.48) [INFO] New connection from 203.70.38.48
    Jun 15 16:33:16 starz pure-ftpd: (?@203.70.38.48) [DEBUG] Command [user] [clammy7777]
    Jun 15 16:33:16 starz pure-ftpd: (?@203.70.38.48) [DEBUG] Command [pass] [<*>]
    Jun 15 16:33:16 starz pure-ftpd: (?@203.70.38.48) [INFO] PAM_RHOST enabled. Getting the peer address
    Jun 15 16:33:22 starz pure-ftpd: (?@203.70.38.48) [WARNING] Authentication failed for user [clammy7777]
    Jun 15 16:33:52 starz pure-ftpd: (?@203.70.38.48) [DEBUG] Command [user] [clammy7777]
    Jun 15 16:33:52 starz pure-ftpd: (?@203.70.38.48) [DEBUG] Command [pass] [<*>]
    Jun 15 16:33:52 starz pure-ftpd: (?@203.70.38.48) [INFO] PAM_RHOST enabled. Getting the peer address
    Jun 15 16:34:01 starz CRON[29017]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
    Jun 15 16:34:02 starz pure-ftpd: (?@203.70.38.48) [WARNING] Authentication failed for user [clammy7777]

    It's driving me nuts!
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Are you sure that clammy7777 is the correct username? normally usernames in ispconfig 3 are somerhing like c0clammy7777
     
  5. clammy77

    clammy77 New Member

    well, I was the admin and I set up the new client as "clammy77"

    And when you create a new ftp user, it says has a fixed and non-writable "clammy77" then a field after it which I filled in 77. I just typed in the password and then submitted.

    I know that the ftp is working because my original owner account is working. but I couldn't get into the other accounts either after ISPConfig was installed.
     
  6. clammy77

    clammy77 New Member

    here, including a screenshot :)
     

    Attached Files:

    • ftp.jpg
      ftp.jpg
      File size:
      31.6 KB
      Views:
      375
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Then FTP is not installed properly. ISPConfig uses virtual user accounts and if you are able to login with a system account, then FTP is not setup properly. Please download the ispconfig 3.0.2.1 tar.gz file, unpack it and run the update.php script. Then choose tp reconfigure services when the updater asks you.

    Also make sure that you installed your server exactly as described in the perfect setup guide.
     
  8. clammy77

    clammy77 New Member

    I have it setup exactly the same way they have it there. That's how i configured it. Well, I mean, I can log into ftp using my original user, BUT, the access is restricted, so I KNOW that ISPConfig has it under control.

    I updated it and everything checks out okay. pure-ftpd is configured successfully, and I don't know what else i need to do...
     
  9. clammy77

    clammy77 New Member

    I checked the owner of the folder, and the owner is web4, which correlates with what it says in ISPConfig. It should be right, but I just can't log in.
     
  10. clammy77

    clammy77 New Member

    Would you happen to know what the problem is? :( I really want to fix this thanks!
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    And thats the part were you are wrong. If you can login with your original Linux system user, then it is installed wrong and it is not controlled by ispconfig. If it would be installed correctly, you would get a login denied for your linux system user as the ispconfig setup uses virtual users and not system users.

    Enable verbose logging in pureftpd and then check the syslog for error messages.

    http://www.faqforge.com/linux/contr...nable-debugging-in-pure-ftpd-on-debian-linux/
     
  12. clammy77

    clammy77 New Member

    I have it on,this is what it shows:


    Jun 17 17:46:16 starz pure-ftpd: (?@203.70.38.48) [INFO] New connection from 203.70.38.48
    Jun 17 17:46:16 starz pure-ftpd: (?@203.70.38.48) [DEBUG] Command [user] [clammy7777]
    Jun 17 17:46:16 starz pure-ftpd: (?@203.70.38.48) [DEBUG] Command [pass] [<*>]
    Jun 17 17:46:16 starz pure-ftpd: (?@203.70.38.48) [INFO] PAM_RHOST enabled. Getting the peer address
    Jun 17 17:46:21 starz pure-ftpd: (?@203.70.38.48) [WARNING] Authentication failed for user [clammy7777]
    Jun 17 17:46:48 starz pure-ftpd: (?@203.70.38.48) [INFO] Logout.
     

Share This Page