Cannot login to SSH after configuring postfix

Discussion in 'Installation/Configuration' started by Crusher55, Jan 31, 2007.

  1. Crusher55

    Crusher55 New Member

    Hi all,
    I've been having problems trying to install ISPConfig onto my VPS. I've been following the perfect setup guides on the site to try and configure it properly but I cannot login to SSH after configuring the postfix portion of the guide and restarting the server. I've tried using both Debian and CentOS 4 (thought Id try using another distro as I thought debian was causing the problems) yet both have the same problem.

    When I try logging in I can input my username and password however after that it just freezes and doesn't proceed any further. I only worked out that postfix was causing this when I kept restarting the server after doing little tasks and only had the problem occur after I installed and configured postfix so I'm pretty sure it's the culprit. Not sure how it's affected SSH in this way though.

    Any suggestions on how to go about this would be greatly appreciated :).

    Edit: http://howtoforge.com/perfect_setup_centos_4.4_p5 is the page I'm up to that causes the problems for CentOS 4 on the guide.
     
  2. martinfst

    martinfst HowtoForge Supporter

    I guess you may have made a typo. Postfix listens on port 25 and ssh on port 22. Otherwise these two programs have nothing to do with each other. They cannot interfere.

    Only other thing I can imagine: you edited the wrong sasl file.

    Or do you have portforwarding on a firewall? And made a typo there? Again 22 vs 25.
     
  3. Crusher55

    Crusher55 New Member

    A friend of mine helped me on IRC. I looked into the problem a bit more, just installing postfix with 'yum install postfix' causes the problem. An interesting thing I noticed was when I enabled postfix (without restarting the server) I couldnt log into a 2nd ssh session although the moment I stopped postfix I was able to log in.

    I think it's something to do with DNS now as well. When I ran postfix I also noticed yum stopped functioning since it could no longer resolve names and I couldn't ping google. Once I stopped the process both worked fine. I'm still not really sure how to go about this though :S.

    I haven't made any typos though and the firewall is disabled at the moment.
     
  4. falko

    falko Super Moderator

    What's in /etc/resolv.conf? What's the output of
    Code:
    netstat -tap
    when Postfix is running?
    Did you disable SELinux?
     

Share This Page