Cannot login to phpmyadmin with remote mysql server

Discussion in 'Installation/Configuration' started by anhlqn, Feb 1, 2014.

  1. anhlqn

    anhlqn New Member


    ISPConfig on Debian Wheezy 7.3

    I follow this guide to install 2 ISPConfig servers as multi-server setup

    I have 2 web server and a separate mysql server. Setup done, ISPConfig run ans sync ok. However, I cannot login to phpmyadmin and get this error

    #2002 Cannot log in to the MySQL server
    I have tried to:
    Config mysql server dns name in files
    - /etc/phpmyadmin/config-db.php
    - /etc/phpmyadmin/
    - /usr/share/phpmyadmin/

    The remote mysql server is configured to allow remote login (ISPConfig runs fine). I think the issue is that phpmyadmin keeps using localhost mysql server, which is not located on webserver, but I cannot find a way to fix this.

    Last edited: Feb 1, 2014
  2. anhlqn

    anhlqn New Member

    I find a way to get phpmyadmin work but I am not sure it supposed to be good with ISPConfig.

    It seems that phpmyadmin does not use the config files in either /etc/phpmyadmin or /usr/share/phpmyadmin, so no matter what I put into these config files, the mysql server is still localhost.

    phpmyadmin use the in /var/lib/phpmyadmin, so I run
    cat /usr/share/phpmyadmin/ > /var/lib/phpmyadmin/
    then change "cookie" to "http" and the mysql server to desired value. Now there is no nice login interface when I visit, but at least I can login to phpmyadmin.

    Any ideas on this issue are appreciated,

Share This Page