Cannot login to ftp!

Discussion in 'Installation/Configuration' started by mpmc, Jun 12, 2006.

  1. mpmc

    mpmc New Member

    hey there, im using ubuntu 6.06 and latest version (off the site) of ispconfig.

    I installed the os using the perfect server setup guide or w/e.

    The first installation, i had problems getting websites to work, but i changed www dirs and etc and got it working, all was well. But it seems at the same time i got it working, ftp access stopped working!

    i uninstalled ISPConfig and reinstalled, got everything back to how it was before, and now this: Using proftp:

    - cannot login to ftp, says username or password is incorrect.

    - passwords ARE correct..

    - tried username and web#_username as login

    - can login as admin so server is running, but cannot login as users made by client making tool

    help would be appreciated...
     
    Last edited: Jun 13, 2006
  2. mpmc

    mpmc New Member

    follow up on my own bit: the situation has changed a bit...

    ok, so when you goto "make new site" and select "FTP Access" (make sure its checked) and save, ISPConfig is not making entries for regular ftp accesss for that user in proftp_ispconfig.conf . Just anonomys.

    AND, if you make a new site with out checking the "FTP Access" box, when you goto view the sites details, its checked anyways. You cant uncheck it.

    maybe somebody can help me now... :D
     
  3. nsm

    nsm New Member

    Did you activate the checkbox "Administrator"? This is needed to allow the user ftp access.

    Also try to connect with the WebFTP Tool in ISPConfig. So you can see if it's a problem with proftp or ISPConfig in general.
     
  4. falko

    falko Super Moderator

    Then something is wrong with your ISPConfig installation... Does the ISPConfig database exist, and are tables in them with records?
     
  5. mpmc

    mpmc New Member

    I've checked the database, It's there, I've even set access to 777 on the proftpd_ispconfig.conf

    Is there some module needed for ISPConfig to create FTP accounts, For example, P.A.M?

    Third time installing this software, It looks good & very useful..

    I'm going to try on my Linux setup (Another PC) & I'll see if I can get it working... (btw, It's two people trying to figure this out)

    I'll post asap...

    UPDATE:

    So I tried this on my machine (different PC)
    I created a site with FTP access, tried to login as 'client' (the name), No luck there..

    disabled FTP.. went back & just as before, It was ticked again <_<...
    Am I missing something, both machines are running Xubuntu 6.06.. (Not as previously stated)

    I'm confused.... been trying to figure this out for days... (3)
     
    Last edited: Jun 13, 2006
  6. BriX

    BriX New Member

    ftp login problem

    I have the same issue. Cannot login using FTP (Ftp client or web-ftp). I've tried everything I can think of. I checked all the tables the information is there. The only solution I have found is to use SCP client to login over SSH.

    Any ispconfig experts want to have a look and see if I missed something? Let me know.
     
  7. mpmc

    mpmc New Member

    What distro are you using?

    We are both running Xubuntu 6.06... but if your having the same issue then it must be ether the distros or the ISPConfig itself..

    Yeah SSH works perfectly... for us too.. I have to start VNC over SSH
     
    Last edited: Jun 13, 2006
  8. falko

    falko Super Moderator

    What's the output of
    Code:
    ls -la /root/ispconfig
    ?
    Can you post the /etc/passwd entry of a user that cannot log in?
    What's in /etc/shells?
     
  9. BriX

    BriX New Member

    Platform info

    The distro is Suse 10.1 x86_64
    ISPCongif 2.2.1 <- correction ISPConfig 2.2.3 just checked

    I am currently running some tests on another server to try and find the problem.
    Falko - I'll check on those commands in a few minutes.

    Update: I posted the information you requested its on the next page.
     
    Last edited: Jun 14, 2006
  10. falko

    falko Super Moderator

    What about my previous questions?
     
  11. BriX

    BriX New Member

    ls -la /root/ispconfig
    -rwxr-xr-x 1 root root 45926 May 2 20:47 cronolog
    -rwxr-xr-x 1 root root 9673 May 2 20:47 cronosplit
    drwxr-xr-x 12 root root 4096 May 2 20:33 httpd
    drwxr-xr-x 12 root root 4096 May 2 20:47 isp
    drwxr-xr-x 6 root root 4096 May 2 20:31 openssl
    drwxr-xr-x 6 root root 4096 May 2 20:37 php
    drwxr-xr-x 4 root root 4096 May 2 20:47 scripts
    drwxr-xr-x 4 root root 4096 May 2 20:47 standard_cgis
    drwxr-xr-x 2 root root 4096 May 2 20:47 sv
    -rwx------ 1 root root 9389 May 2 20:47 uninstall

    /etc/passwd
    web_em:x:10001:10001:Webmaster:/var/www/web1:/bin/false

    /etc/shells
    /bin/ash
    /bin/bash
    /bin/bash1
    /bin/csh
    /bin/false
    /bin/ksh
    /bin/sh
    /bin/tcsh
    /bin/true
    /bin/zsh
    /usr/bin/csh
    /usr/bin/ksh
    /usr/bin/passwd
    /usr/bin/bash
    /usr/bin/rbash
    /usr/bin/tcsh
    /usr/bin/zsh
    /SENDMAIL/ANY/SHELL/

    Ok that's what you were looking for I hope.
     
  12. mpmc

    mpmc New Member

    Code:
    total 100
    drwxr-xr-x  9 root root  4096 2006-06-13 17:01 .
    drwxr-xr-x 12 root root  4096 2006-06-11 23:58 ..
    -rwxr-xr-x  1 root root 33502 2006-06-12 00:01 cronolog
    -rwxr-xr-x  1 root root  9673 2006-06-12 00:01 cronosplit
    drwxr-xr-x 12 root root  4096 2006-06-11 23:23 httpd
    drwxr-xr-x 12 root root  4096 2006-06-12 00:01 isp
    -rw-r--r--  1 root root    14 2006-06-13 17:01 .old_path_httpd_root
    drwxr-xr-x  6 root root  4096 2006-06-11 23:14 openssl
    drwxr-xr-x  6 root root  4096 2006-06-11 23:46 php
    drwxr-xr-x  4 root root  4096 2006-06-12 00:01 scripts
    drwxr-xr-x  4 root root  4096 2006-06-12 00:01 standard_cgis
    drwxr-xr-x  2 root root  4096 2006-06-12 00:01 sv
    -rwx------  1 root root  9389 2006-06-12 00:01 uninstall
    
    passwd
    Code:
    root:x:0:0:root:/root:/bin/bash
    daemon:x:1:1:daemon:/usr/sbin:/bin/sh
    bin:x:2:2:bin:/bin:/bin/sh
    sys:x:3:3:sys:/dev:/bin/sh
    sync:x:4:65534:sync:/bin:/bin/sync
    games:x:5:60:games:/usr/games:/bin/sh
    man:x:6:12:man:/var/cache/man:/bin/sh
    lp:x:7:7:lp:/var/spool/lpd:/bin/sh
    mail:x:8:8:mail:/var/mail:/bin/sh
    news:x:9:9:news:/var/spool/news:/bin/sh
    uucp:x:10:10:uucp:/var/spool/uucp:/bin/sh
    proxy:x:13:13:proxy:/bin:/bin/sh
    www-data:x:33:33:www-data:/var/www:/bin/sh
    backup:x:34:34:backup:/var/backups:/bin/sh
    list:x:38:38:Mailing List Manager:/var/list:/bin/sh
    irc:x:39:39:ircd:/var/run/ircd:/bin/sh
    gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/bin/sh
    nobody:x:65534:65534:nobody:/nonexistent:/bin/sh
    dhcp:x:101:101::/nonexistent:/bin/false
    syslog:x:102:102::/home/syslog:/bin/false
    klog:x:103:103::/home/klog:/bin/false
    cupsys:x:100:106::/home/cupsys:/bin/false
    messagebus:x:104:107::/var/run/dbus:/bin/false
    haldaemon:x:108:108:Hardware abstraction layer,,,:/var/run/hal:/bin/false
    hplip:x:105:7:HPLIP system user,,,:/var/run/hplip:/bin/false
    gdm:x:106:111:Gnome Display Manager:/var/lib/gdm:/bin/false
    admin:x:1000:1000:Steven Dorman,,,:/home/admin:/bin/bash
    sshd:x:107:65534::/var/run/sshd:/bin/false
    fetchmail:x:109:65534::/var/lib/fetchmail:/bin/sh
    bind:x:110:112::/var/cache/bind:/bin/false
    mysql:x:111:113:MySQL Server,,,:/var/lib/mysql:/bin/false
    postfix:x:112:115::/var/spool/postfix:/bin/false
    ftp:x:113:65534::/home/ftp:/bin/false
    admispconfig:x:1001:1001:Administrator ISPConfig:/home/admispconfig:/bin/bash
    shells
    Code:
    # /etc/shells: valid login shells
    /bin/ash
    /bin/bash
    /bin/csh
    /bin/sh
    /usr/bin/es
    /usr/bin/ksh
    /bin/ksh
    /usr/bin/rc
    /usr/bin/tcsh
    /bin/tcsh
    /usr/bin/zsh
    /bin/sash
    /bin/zsh
    /usr/bin/esh
    /bin/rbash
    /usr/bin/screen
    /bin/false
    /SENDMAIL/ANY/SHELL/
    /SENDMAIL/ANY/SHELL/
     
  13. falko

    falko Super Moderator

    @mpmc: I don't see any users in /etc/passwd created by ISPConfig...

    @BriX: Looks ok. And you're trying to connect as web_em and with the correct password?
     
  14. mpmc

    mpmc New Member

    So are we doing something wrong or isn't it writing to the passwd file?
     
  15. BriX

    BriX New Member

    Yes for sure I have the correct password. I have even set it a few times to make sure. So do you recommend anything else? Fresh install? :(
     
  16. mpmc

    mpmc New Member

    I've tried a fresh install umm.. 3 times now with the same results..
     
  17. mpmc

    mpmc New Member

    Thanks all..

    We noticed that you had to have 1 reseller to create accounts/ users.. then create the users on the reseller & enable users that way, we thought the reseller would have FTP access..

    Thanks falko, You made me think what the problem was...
     
  18. till

    till Super Moderator

    Resellers and clients are no system users, so they can never get FTP access.
     
  19. falko

    falko Super Moderator

    What's the exact error message your FTP client is giving you? Any errors in the logs? Which distribution do you use?
     

Share This Page