Cannot login through Admin Panel

Discussion in 'General' started by madelves, Dec 16, 2013.

  1. madelves

    madelves New Member

    Hi,

    I have a problem with an already running ispconfig 3.

    I cannot login through the login panel now. I can open PHP my admin but it always says error mysql 1045. however I can login using mysql -u 'username' -p

    I have looked at various log it seems the problem is about connecting to the database. I changed the config.inc.php in both /usr/local/ispconfig/interface/lib and /usr/local/ispconfig/server/lib to reflect the current mysql password.

    FYI : my server was just ddos'ed by another person and this happens

    Tried all kinds of stuff but at a loss right now.

    Please help.

    Regards,
    Ray
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do not change the mysql password of the ispconfig user in these files manually. If you want to set a password in mysql,take the password that is inserted into the files by the ispconfig installer and set this password in mysql. So the other way round as you did it. The password is used in many more files and if you alter it manually, most parts of the system will start to fail.

    After you restored the files, we can strt to search for your original problem:

    post the output of:

    nestat -tap | grep mysql
     
  3. madelves

    madelves New Member

    How do I do that manually? I am using ispconfig 3.0.3.2

    netstat shows :

    tcp 0 0 localhost.localdo:mysql *:* LISTEN 27716/mysqld
     
  4. madelves

    madelves New Member

    I tried and cannot do anything. It still shows cannot connect.

    How do I reset my main user/password for mysql for ispconfig? Is there a script I can use?

    I can't even do an install script for upgrading because it somehow cannot connect to mysql.

    php -q update.php shows :

    Code:
      | | \ `--.| |_/ / | /  \/ ___  _ __ | |_ _  __ _    _/ /
      | |  `--. \  __/  | |    / _ \| '_ \|  _| |/ _` |  |_ |
     _| |_/\__/ / |     | \__/\ (_) | | | | | | | (_| | ___\ \
     \___/\____/\_|      \____/\___/|_| |_|_| |_|\__, | \____/
                                                  __/ |
                                                 |___/ 
    --------------------------------------------------------------------------------
    
    
    >> Update  
    
    Operating System: Debian 6.0 (Squeeze/Sid) or compatible
    
    This application will update ISPConfig 3 on your server.
    
    Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]: 
    
    Creating backup of "/usr/local/ispconfig" directory...
    Creating backup of "/etc" directory...
    Unable to connect to mysql server Access denied for user 'root'@'localhost' (using password: NO)
    MySQL root password [1234567]: 1234567
    
    Unable to connect to mysql server Access denied for user 'root'@'localhost' (using password: NO)
    MySQL root password [1234567]: 
    PS : I use 1234567 for security's sake
     
  5. madelves

    madelves New Member

    Found out what's wrong.

    It turns out the mysql safe mode is messing around with ispconfig.
    I've been hardening the server and turning it off makes it ok for me to log in.
    Can I do PHP safe mode with ispconfig?
     

Share This Page