Cannot login into mail, ftp..(Access denied for user 'ispconfig)

Discussion in 'ISPConfig 3 Priority Support' started by demon326, Feb 12, 2019 at 4:49 PM.

  1. demon326

    demon326 New Member HowtoForge Supporter

    So about a day ago i noticed the server stopped sending/receving e-mails... I checked the ispconfig 3 log and it shows the following error:
    Code:
    Feb 12 16:38:48 vps1309 postfix/proxymap[7238]: warning: connect to mysql server 127.0.0.1: Access denied for user 'ispconfig'@'127.0.0.1' (using password: YES)
    
    I also cannot access any ftp account, despites the right user/passsword combo and amivis is also complaining about mysql stuff. I did not change any server setting, which makes me think there has to be more than the eye meets.

    What did i tried:
    mysql -u ispconfig -p <password> --->works.
    mysql -h 127.0.0.1 -u ispconfig -p <password> ---> does NOT work.
    restoring 2 week old server image: did not work, same issue

    What works:
    Creating/editing mysql databases
    I can access ispconfig without any problems
    it still updates mail/ftp passwords.(i checked the DB records, there changing)
    my websites still have database access, no problems here.
    ----------------------------------------------------------------------
    iam getting pretty desperate since i cannot access the services that i need
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check your MySQL config to ensure that you did not disable the network stack in MySQL. Maybe you tried to optimize the MySQL config and some tools suggest to disable the network stack for that, which is a bad idea as all services that connect to MySQL over local IP will fail then.
     
  3. demon326

    demon326 New Member HowtoForge Supporter

    Hi till,

    you mean this line in my.cnf ? :
    Code:
    bind-address = 127.0.0.1
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This setting is ok. I mean the setting skip-networking which may not be enabled.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    And you should check /etc/hosts to ensure that localhost is bound to IP 127.0.0.1 and not to a different IP.
     
  6. demon326

    demon326 New Member HowtoForge Supporter

    Okay, that was the issue... i commented the following lines:
    skip-name-resolve
    skip-networking

    and it started working again!

    I always restart mysql after making changes to the config file, just to be sure it all works and it did untill a few days ago when mysql restarted..

    That setting is okay.
     

Share This Page