Cannot log into new email created after upgrade

Discussion in 'ISPConfig 3 Priority Support' started by vigilin, Feb 1, 2017.

  1. vigilin

    vigilin New Member HowtoForge Supporter

    Hello,
    I have an issue with my ISPConfig servers. I have 2 servers in a master-slave setup on Ubuntu 14.04 LTS.
    I ran apt-get upgrade on both servers. Then ispconfig_update.sh on the master, and then on the slave.
    I tried creating a new email box. It gets created, but I cannot log in. I get the following error:
    "date/time" "servername" dovecot: imap("emailaddress" ): Error: user "emailaddress": Initialization failed: Initializing mail storage from mail_location setting failed: Unknown setting: /var/vmail/"domain"/"user"/
    "date/time" "servername" dovecot: imap("emailaddress" ): Error: Invalid user settings. Refer to server log for more information.

    I tried postfix set-permissions, but I get:
    chown: cannot access '/usr/lib/postfix/dict_cdb.so': No such file or directory

    Ran postfix upgrade-configuration as well.

    That lib is not there in that directory. It's a little bit beyond my skill set at this point. Any help would be greatly appreciated.
     
    Last edited: Feb 1, 2017
  2. vigilin

    vigilin New Member HowtoForge Supporter

    PS, I took a VMWare snapshot, so I can go back if I need to, but I don't want to wait too long.
     
  3. vigilin

    vigilin New Member HowtoForge Supporter

    So I ventured into the /var/vmail/"domain"/"user"/ and it looks like the config is different now.
    On an existing user from before the upgrade there is the following:
    dir: Maildir
    file: .quotausage
    file: .sieve
    file: .sieve.svbin

    On a user the was created after the upgrade there is the following:
    dir: Maildir
    dir: sieve
    file: .sieve -> sieve/ispconfig.sieve
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The difference should be fine and not the reason for the problem, it's just a newer layout.

    Which error did you get in the mail.log file of the server when you tried to login? Another possibility to debug this is that you compare the newly created user in the mail_user table of the ispconfig database with a working one, maybe a setting is missing. You can do that e.g. with phpmyadmin.
     
  5. vigilin

    vigilin New Member HowtoForge Supporter

    At login I get in the mail.log:
    "date/time" "servername" dovecot: imap("emailaddress" ): Error: user "emailaddress": Initialization failed: Initializing mail storage from mail_location setting failed: Unknown setting: /var/vmail/"domain"/"user"/
    "date/time" "servername" dovecot: imap("emailaddress" ): Error: Invalid user settings. Refer to server log for more information.

    I don't know what log it's referring to when it says "server log"

    I will check the db in a bit
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The mail log file of the server is normally:

    /var/log/mail.log

    or

    /var/log/maillog
     
  7. vigilin

    vigilin New Member HowtoForge Supporter

    No, I mean in the mail.log statement it says to refer to the server log for more information. Not sure which log it means.
     
  8. vigilin

    vigilin New Member HowtoForge Supporter

    Till,

    The new user is missing the maildir entry under maildir_format

    I went over to the Server Config on the GUI and under mail it is set to Maildir Format: Maildir

    Let me know what I need to do, Thanks
     
  9. vigilin

    vigilin New Member HowtoForge Supporter

    I decided to try something while I waited.
    manually adding maildir into the record seems to fix the problem, I can now log on.
    I created another new mailbox, and this time it added the maildir in maildir_format.

    I have no explanation for this, nothing was changed since the problem presented itself (except I installed phpmyadmin in the secondary server)
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    This might have fixed it:

    The value was maybe not stored correctly by ispconfig in the settings and that action corrected it.
     

Share This Page