Cannot Log In after perfect desktop/perfect server setup

Discussion in 'HOWTO-Related Questions' started by jkrell, Dec 16, 2008.

  1. jkrell

    jkrell New Member

    Hi all!

    I installed Fedora 10, did some of the "Perfect Desktop" stuff, did the "Perfect Server" setup from start to finish, then installed ISPConfig. The only other things I did that were not in your tutorials were (1) set up auto-login in gdm.schemas, (2) set up samba-swat and enabled a share and (3) installed Jinzora.

    These were not done in the order explained above. Instead, it was like this:

    1. install Fedora ==> 2. auto-login ==> 3. static IP ==> samba-swat and share ==> 4. perfect desktop stuff (85% of your tutorial) ==> 5. perfect server from start to finish ==> 6. installed Jinzora.

    The only problems I really had were static IP twitchiness (which I worked out though I cannot say how for sure), problems with Gnome services GUI (I disabled services using chkconfig instead) and problems with Jinzora seeing my media.

    Somewhere after step 3, I lost my ability to log into the system. With auto-login enabled, it boots up fine (though it seems to hang at the very end of the part where the bars go across the bottom of the screen), but then at the login screen it shows "autologin" but it does not do anything and you cannot click anywhere (and the shutdown, reboot, etc. options are all grayed out). If I turn auto-login off, then it behaves the same, except instead of "autologin" it says "other." Still no clicking and all the options are grayed out.

    Problem is, I do not know what caused this since I am working on the computer remotely. From my remote location, I am able to SSH/SFTP into the box, and the websites come up fine, and Jinzora functions (despite problems seeing my media). The one thing I noted was that I was moving some of my media from /home into / and the system crashed and I had to have my wife reboot the machine. It first complained of the filesystem being read-only (not true) and then said "bus error" when I tried to reboot through ssh. My wife rebooted, and we noticed that it would not log in. So this might relate to the Jinzora issues or (perhaps more likely) it could be from something else during the process.

    Have you ever seen this behavior at the login screen? Any way to troubleshoot this? Where do I find the boot log?

    Thanks for your ideas, if you have any. This happened yesterday and I thought redoing everything would work, but I ended up with the same problem.
  2. falko

    falko Super Moderator ISPConfig Developer

    Please remove
    from /etc/shells.
  3. jkrell

    jkrell New Member

    Thanks, Falko -- I'll try that and report back.
  4. jkrell

    jkrell New Member

    Did the trick. I should have remembered this from last time but did not. Anyway, now have F10 up and running and perfect server setup running smoothly with Jinzora, WordPress, Gallery2, etc. Wonderful stuff.

Share This Page