Cannot index pages

Discussion in 'Installation/Configuration' started by llamy, Jun 27, 2007.

  1. llamy

    llamy New Member

    Hi Falko and all,

    Thanks very much for the forums and your help for the linux community.
    I, myself i'm a linux biguinner with some serious questions i did not find
    any answers yet for about 3 days now even in the forums. So please Falko, and everyone else, your help will be once more greatly appreciated. Thx.

    here is the environnement :

    I have just installed Fedora core 6 with your tutorial the perfect lamp server. The installation of ISPConfig was very good and everything is working fine except that postfix gives some errors at system shutdown, but i will have to check the postfix logs to see what it is exactly, but at this time i have this issue now which is much more important for me.

    here is the issue :
    when i try to access my website by ( it gives me the following error page :
    Not Found
    The requested URL /index.html was not found on this server.
    but when i type ( in the url i get the apache welcome. This is the only page i get on my site i cannot even get it through the

    To try to solve that i added the following directive with ISPConfig:

    <Directory /var/www/>
    # i have also tried with /var/www/ but still same !#results.
    Options +Includes +FollowSymlinks -Indexes
    AllowOverride All
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all

    But still the problem is there. After that i modified my httpd.conf to

    AllowOverride All
    instead of
    AllowOverride None

    But like before after restarting ISPConfig server, the problem is still there. So i changed it back to the normal httpd.conf file. Here is the exact copy of my httpd.conf file. And i do not have any .htaccess file in /var/www/web1/web.

    Please help me! i fill lost now for 3 days. Thanks very much.
  2. llamy

    llamy New Member

    i send now the httpd.conf in attachment

    the httpd.conf is attached in file httpd.conf.txt.

    Thanks again for your help.

    Attached Files:

  3. llamy

    llamy New Member

    Any clue!

    Hi, I know it might be a stupid question but, does anyone here knows what the problem might be ?

    thanks for your reply
  4. llamy

    llamy New Member

    output of my error log file

    Here is the output of my error log file.

    [Wed Jun 27 06:10:27 2007] [error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
    [Wed Jun 27 06:10:35 2007] [error] [client ::1] File does not exist: /var/www/html/index.html

  5. llamy

    llamy New Member

    I got it working!

    Using the error log i noticed that the error was about a directive of indexes forbiden in the directory /var/www/html but this is not what it was supposed to be as the directory but instead should be /var/www/mywebsitename/* so i figured out that i was not typing the write url since the site is still on test (no valid url so far) and accessing it through http://localhost or http://IP_address will not work. i added an entry in /etc/hosts for the name "mywebsitename" (which is the name of the my website in ISPConfig) and now when i access the site by typing: http://mywebsitename, it just works fine now.

    Thanks guys!

Share This Page