Cannot Generate CSR

Discussion in 'Installation/Configuration' started by fathertime, Feb 10, 2010.

  1. fathertime

    fathertime New Member

    Thanks to Till, I can now begin where I left off. The last piece of the puzzle is SSL. I think that I could work through the installation as soon as I can get ISPConfig to generate a CSR. Blank every time.

    I read that one of my sites may have ssl enabled, so I checked that, and there is no other site showing SSL enabled.

    I'm thinking that it may be because my is kind of split up between two different site locations on the server:

    I have been making sure that I have SSL enabled. I access my site using and access the phpmyadmin, webmail, and ISPconfig using I have two different sites for the two urls. I use a redirect page to link to the main page, which resides at

    It is a GoDaddy 2048 ssl that I have purchased. I see quite a few different ways to go about setting up the ssl once you have the csr.

    The is located at /var/www
    The is located at /var/www/

    Any ideas on how to get it to generate a CSR?

    Thank you,

    Last edited: Feb 10, 2010
  2. fathertime

    fathertime New Member

    additional information - Cannot Generate CSR

    I forgot to mention that i have done some security modifications.

    ServerSignature OFF
    ServerTokens Prod

    /etc/php5/apache2 - cgi - cli
    expose_php off
    display_error off
    disable_function = show_source, system, shell_exec, passthru, exec, phpinfo, popen, escapeshellarg, escapeshellcmd, proc_open

    I hope that helps some.

    Thanks again,

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Very bad Idea. You just disabled ISPConfig by disallowing it to execute any commands like the openssl command. Undo all changes for cli php. cli php is on the shell only, so disabling shell exec in a shell script just does not make any sense, as it is already a shell script.
  4. fathertime

    fathertime New Member

    Thank you.

    Thank you, thank you, thank you.

    It's working.:D

Share This Page