Cannot fetch mail from directory...

Discussion in 'Installation/Configuration' started by ctroyp, Mar 15, 2007.

  1. ctroyp

    ctroyp New Member HowtoForge Supporter


    I have had this system running for over a year now and I am still having a problem with fetching mail from my mail directory. Until now I have just forwarded all mail to my Yahoo account.

    All mail is delivered to the relevant directory /var/www/web8/user/web8_admin/Maildir/new/

    The problem is that any mail client that I have tried cannot fetch these emails.
    I have tried squirrelmail, roundcude, uebimiau, thunderbird, and outlook without success. I can send email using any of them, but I cannot ever see what is received.

    Please let me know any ideas you may have. After a year, I am very desperate in finding a solution. I spend far too much time working between my own email client sending emails that I have received in Yahoo.

    Thanks in advance...
  2. ctroyp

    ctroyp New Member HowtoForge Supporter

    Ah, this is funny (well not really). I just figured this out after all this time.

    I have always had a suspicion that this had something to do with the chroot functions for ssh access that I applied about the same time that I lost the email functionality. There is a problem with the "./" in the user entry in the passwd file. I can access my mail if I simply remove the "./".

    Falko, do you have any idea why this would have killed my access to the mail folders?
  3. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    In which field was the ./? Fields in /etc/passwd are separated by ':' I mean what's the field number, when starting to count from 1 and from left to right?
  4. ctroyp

    ctroyp New Member HowtoForge Supporter

    It was in the 6th field, the directory...
  5. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    The . means: start from current directory. It should normally never be in /etc/passwd. It should always contain the full absolute pathname starting with a '/'.

    But I'm not familiar with chrooted ssh, so that may be the reason why you have it there. I simply don't allow users (except myself) on my systems. FTP is good enough to upload files for websites. If they want more, customers can rent a dedi server (or a virtual private server)
  6. ctroyp

    ctroyp New Member HowtoForge Supporter

    I originally setup the chroot ssh for a friend that was running a few sites on my server, but that has fallen apart now so maybe I need to remove the ability.

    Thanks for the help...btw, I see that you are in Hilversum. I am travelling to Rotterdam to do some work for a few days in June, I think. Not too far from you.

    Anyhow, thanks again!
  7. mlz

    mlz New Member

    Personally, I'd like to resolve this problem. I have way too many people that need ssh, and I don't need people using the system to hack other sites. I'm trying to dig into why the mail won't work correctly with chroot, but wonder if anyone else is working on it as well.
  8. ctroyp

    ctroyp New Member HowtoForge Supporter

    Thanks for the retained interest. I have had second thoughts as well and have not removed my chroot mod yet. When I get a little extra time, I will look back into it...

Share This Page