cannot execute /usr/sbin/pure-ftpd-wrapper error

Discussion in 'Installation/Configuration' started by phall472, Jan 7, 2010.

  1. phall472

    phall472 New Member

    Hello

    After trying to get vsftpd and mysql-pam to work without success, I decided to try pure-ftpd.

    I had my host re-install Debian 5 and I have set everything up from that point.

    I installed Apache 2.2, PHP 5, MySQL 5, and pure-ftp.

    I followed http://www.howtoforge.com/pureftpd_mysql_virtual_hosting

    but I am receive and connect failed when I try to connect with SmartFTP.

    I found the syslog and it says

    pure-ftpd-wrapper[2080]: error: cannot execute /usr/sbin/pure-ftpd-wrapper: Permission denied

    I read on the web there is a bug somewhere in the pure-ftpd-wrapper but I could not find it.

    Please help.

    Thank you
     
  2. till

    till Super Moderator

    Please make sure that security extensions like selinux and apparmor are disabled.
     
  3. phall472

    phall472 New Member

    Hello

    Thanks for replying.

    I am very new to Debian and my hosting service is totally inept.

    Can you explain what you are referring to? Or direct me to a tutorial on selunix and apparmor that will tell me if they are disabled or enabled.

    Thank you
     
  4. falko

    falko Super Moderator

    On Debian, SELinux and AppArmor are usually disabled.
    Is this a physical server or a virtual machine? If it's a virtual machine, what virtualization technique are you using (OpenVZ/Virtuozzo, Xen, KVM, VMware, etc.)?
     
  5. phall472

    phall472 New Member

    Hello

    Please disregard this thread I have dicovered that pure-ftpd was not starting at all. So I made a new thread on my problem with that.


    Just to answer the question it is a dedicated server and I was attempting to set it up using pure-ftpd and mysql.

    Thank you
     
    Last edited: Jan 8, 2010

Share This Page