Cannot create Websites :'( nothing in /var/www/clients

Discussion in 'Installation/Configuration' started by silou, May 12, 2010.

  1. silou

    silou New Member


    I'm nee to ISPConfig and I'm facing a few by major problem :

    I cannot create any website on ISP Config / Debian / OVH RPS hosting

    The domain points to the index.html "It Works" standard page and there is no /var/www/clients/??? directory created.

    May someone help me please ? I have no clue at the moment.

    + Moreover the /etc/apache2/httpd.conf file has a 0 length. Strange... perhaps the good file is /etc/apache2/apache2.conf ?
    + I have updated debian with its latest packages. Nothing changed. Who knows
    + the sites i've created are not written inside the files located at /etc/apache2/, /etc/apache2/sites-enabled/, /etc/apache2/sites-available/
    + I've followed the tuto (add a DNS and then a site). Nothing new.
    + I've followed the infos from but did'nt succeed in creating a website.
    Last edited: May 12, 2010
  2. CSsab

    CSsab New Member

    sites available directory

    This is the contents of my /etc/apache2/
    root@csa:~# cd /etc/apache2/
    root@csa:/etc/apache2# ls
    apache2.conf conf.d envvars httpd.conf magic mods-available mods-enabled ports.conf sites-available sites-enabled
    root@csa:/etc/apache2# cd sites-available/
    root@csa:/etc/apache2/sites-available# ls
    apps.vhost default default-ssl ispconfig.conf ispconfig.vhost

    This is with one working website.

    Are you sure apache is running?

    Try /etc/init.d/apache2 restart
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    - Make sure that the cron daemon is started.
    - Are there any jobs left in the jobqueue in the ispconfig monitor?
  4. silou

    silou New Member



    It seems that isp created the domain with a delay.
    I didn't know there was a job queue for ISP.

    here is my directory compared to yours :

    root@ovh:~# cd /etc/apache2/
    root@ovh:/etc/apache2# ls
    apache2.conf conf.d envvars httpd.conf mods-available mods-enabled ports.conf sites-available sites-enabled ssl
    root@ovh:/etc/apache2# cd sites-available/
    root@ovh:/etc/apache2/sites-available# ls default default-ssl ispconfig.conf ispconfig.vhost

    conclusion : .vhost file has appeared a few minutes (or hours) after. Don't know how and when it was created.

    Then, there was several directories created due to my tests.


    Yes the daemon is up (I suppose you are talking about the daemon of isp that checks every minute inside the ISP job queue).
    And the job queue is working.

    Well, I don't know what happened. Thank you for your support. But truely, i tried for many hours to make ISP work. I must have modified something that was blocking the control panel.

    Will have to make some more tests before restoring my websites.


Share This Page