Cannot Create New MySQL Databases

Discussion in 'General' started by faster, Dec 10, 2010.

  1. faster

    faster New Member

    I have ISPConfig3 setup on an Ubuntu server and followed the excellent guide here. After initially setting up the server I was able to create some MySQL databases through ISPConfig. I could log into those MySQL databases through PHPMyAdmin. Now I cannot.

    I create the database, user, and select the site through ISPConfig. No errors or anything. When I attempt to log into MySQL it basically gives me a error: #1045 Cannot log in to the MySQL server. I also cannot log into the database with the newly created MySQL username / password through at the terminal. mysql -u user -pPassword

    I need to create some new databases for new sites. Any help or suggestions would be awesome. I've checked the logs and have not see anything.
     
  2. faster

    faster New Member

    When I log into the database as root through the termainl, then run select host, user, password from mysql.user; it does not show any of the users I've created.

    What would prevent ISPConfig from creating users or databases?

    Thanks
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Make sure that your database details in /usr/local/ispconfig/interface/lib/config.inc.php are correct.
     
  4. faster

    faster New Member

    I just checked that and mysql_clientdb.conf and everything looks correct. Is there anything that should stand out in the conf files?

    I was able to mysql -u root -pPassword based on the info in mysql_clientdb.conf.

    Any other suggestions? Thanks
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats good, the credentials in that file are used to create the databases. Please try also to use the hostname as it might be related to the hostname when the login fails.

    mysql -h localhost -u root -pPassword

    Are there any non processed changes listed in the ispconfig monitor in the jobqueue?
     
  6. faster

    faster New Member

    Tried: mysql -h localhost -u root -pPassword and it worked correctly.

    In my Jobqueue i have a lot of insert / delete / update to web_database table. It seems these are all the database creations I have been trying to do but yet not going through.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so there is a problem that has stopped the job processing. Please check in ispconfig under monitor > system log if there are any errors listed there.
     
  8. faster

    faster New Member

    ISPConfig System-Log does not show any issues.

    I followed this thread: http://www.howtoforge.com/forums/showthread.php?t=45407 and it seems to be the same thing but I am not sure how to fix it.


    select datalog_id from sys_datalog; returns 138 as the last result but

    mysql> select updated from server; returns 137.

    Not sure how to make it sync so I can create databases.

    Thanks
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    This is a quite old bug, so you should update your server to a current ispconfig release.

    Then change the number in the updated field in the server table to the number of the first unprocessed record from sys_datalog. You can find that record e.g. by counting the number of records that show up in the jobqueue in the monitor.
     
  10. faster

    faster New Member

    Ran sudo apt-get upgrade
    Downloaded and updated ISPConfig to 3.0.3.2

    Currently in my JobQueue I have one thing pending.


    select datalog_id, status from sys_datalog order by datalog_id;

    Shows 138 items pending. Does it matter there are that many pending in there but only one item showing up in JobQueue?

    select updated from server; returns 137.

    I set the updated column to 138 and rebooted the server.

    After reboot I tried to make a database but it failed.

    Same issue. sys_datalog shows 139 items but updated column only shows 138.

    Any suggestions?

    Also the database I create show sup in web_database but nothing when listing actual databases in mysql nothing shows up.

    Thanks
     
    Last edited: Jan 12, 2011
  11. faster

    faster New Member

    Ran the update script and it looks like it fixed everything.

    I am all set.

    Thanks for your help!
     

Share This Page