Cannot create my own Sites

Discussion in 'Installation/Configuration' started by learning, Dec 1, 2006.

Thread Status:
Not open for further replies.
  1. learning

    learning New Member


    The following error occurred:

    The name is already in use by another site or domain.

    Why can't I get rid of this?? I've been working fine with the CP until I decided to delete two of my three sites, this so I can concentrate on fixing the main DNS issues. I was finally able to see the one site. But when I go back to re-configure the other two, I getthe error below.

    I have, Restarted the Server and the Bind DNS service, cleared my Browser Cache and Cookies, but still the same error. This is frustrating..

  2. learning

    learning New Member

    Any ideas?

    No responses, guess I'll have to re-install for fourth time.. :(
  3. learning

    learning New Member


    This program is VERY "finicky". Any problems, Reinstall. That did the trick.

    Important: Delete all references to ISPconfig, admispconfig, all ISPConfig databases, installation directories, Everything.. prior to reinstalling.

    Good Luck !!
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig has a recycle bin like windows, macos, kde, gnome, etc.

    Reinstallation was not nescessary at all. The domain was in the recycle bin. Just empty the recycle bin and you will be able to create a site with the same domain again.

    Better to search the forum first for an answer before you reinstall ;)
  5. learning

    learning New Member

    Didn't work

    Hello Till, thank you for responding.

    I did empty my recycle bin and it still said the same error. The same is happening now with an e-mail "user name" now. So I just created another name and decided to forget about the old one. Too bad since it was my personal name. : ( .

    BELIEVE me. I'd rather look for a solution before re-installing. My hands tremble when I try to install ISPConfig.

    Last issue I have is getting POP3 Online. From Webmin I can start "Sendmail" or "Postfix" and I have, but no help. Are any of these supposed to work? or do I have to install "Qmail" or something. Can you advise, asap? I've been without e-mail for a week now.

    Thank you,

    Last edited: Dec 3, 2006
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    I'am absolutely sure that the items where in one of your recycle bins. There is one for every reseller and one for the admin.

    Did you follow one of the perfect setup guides? These problems happen when you use ISPConfig together with another controlpanel like webmin.
  7. learning

    learning New Member


    I did not install "The Perfect Setup" since I thought it did not apply to me. I am running a remote dedicated server with Webmin access. So I skipped some steps that I guess were required. The most important one being the very important Postfix Configuration. So I have just tried the steps and everything was going smooth except for the errors below. How should I proceed??... Richard

    Perfect Setup - Postfix Config Error

    > chmod 600 smtpd.key
    > openssl req -new -key smtpd.key -out smtpd.csr
    unable to load Private Key
    9121:error:0906D06C:pEM routines:pEM_read_bio:no start line:pem_lib.c:644:Expecting: ANY PRIVATE KEY
    > openssl x509 -req -days 3650 -in smtpd.csr -signkey smtpd.key -out smtpd.crt
    smtpd.csr: No such file or directory
    Last edited: Dec 4, 2006
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    That explains all your problems. The perfect setups are the installation howtos for ISPConfig, if you want to use ISPConfig ist better to follow the exact line by line. If you want to skip parts, you must really know what you are doing and how ISPConfig works!

    You must copy the commands line by line and not all commands at once! The SSL creation is a interactive script.
  9. learning

    learning New Member

    Very True

    Hello Till,

    I will agree on needing to go by the "Perfect Onstall" BEFORE anything. The commands forthe Postfix config took me about one hour (a batch file would be nice). I was also using a commmand shell at first. I guess I was able to complete the work and I FINALLY got rid of the>>mail server erros. So I guess I've one tha far. BUT, i STILL am having problems.

    I use Thunderbird (windows version). I am able to connect now but when I try to send, it was returning my e-mails saying it could not send "Realy accesss denied", now I dont even get that (dont know what i did). I also tried from a yahoo account and no luck, UEIBIMAIO program keeps giving me Login errors. I've searched everywhere for the problem now. "The wife is about to divorce me" :( , but I need my email... Any help on this one? I need to send/receive from my client but I also don't want to relay mail from spammers. That is the reason why I got into this mess last week. Its been 10 days now.

    Im' willing to give you access at this point.. just authorize..

    Thanks again,


    postfix/ file

    readme_directory = /usr/share/doc/postfix-2.2.8/README_FILES
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom

    Question: Do I have to do some setting in the Dovecot.conf file?? the file seems to have everything "commented out". if so, PLEASE send me a sample configuration...thanks
    Last edited: Dec 4, 2006
  10. learning

    learning New Member

    Thread Closed

    Voluntarily closed thread. Transfered to ne thread tiltled, "Relay Access Denied"
Thread Status:
Not open for further replies.

Share This Page