cannot create db's for a site -and ISPconfig deletes existing db's

Discussion in 'Installation/Configuration' started by bas, May 27, 2009.

  1. bas

    bas New Member

    Hello

    I have a bit of a problem right now.

    Have been running ISPConfig quite some time. Always worked perfectly.
    Some time ago it seemed someone hacked my system. So i took my backup and rebuild the system completely. Also immediately upgraded to the lastest OS version and the latest ISPConfig version.
    I've followed the steps mentioned elsewhere on this forum. And got everything running again.

    All seemed to be fine.
    Except when i tried to create a new database for an existing site - the button isnt there anymore. In the site-definition is still shows that there were already multiple database, but if i then save the site ISPConfig will actually delete all those databases.

    So i need to find a way to allow the creation of databaes again. And then i hope once that's fixed that the automatic removing of databases will stop too.
    (right now i have to create my db backup - so that if by accident i make a change in a sitedefinition, i can instantly re-create and replace the database).

    Hope someone can give me a hand.

    I am running version 2.2.32, on ubuntu 9.04 (server)

    Thanks
    Bas
     
  2. till

    till Super Moderator

    The document type definitions in your database are not correct for the installed version. I guess you used the doctype table from your old version as you restored the backup. To fix this, download the latest ispconfig 2 version again and run the setup script to update your installations. It is ok if its the same version that you have currently installed.
     

Share This Page