Cannot create client, reseller and hosting plan

Discussion in 'Installation/Configuration' started by crapufish, Mar 12, 2007.

  1. crapufish

    crapufish New Member

    Hello!

    I just installed ISPConfig (version 2.2.11 on Ubuntu 6.10). I am trying to add an client but it sais: "The requested document type does not exist" everytime I click on "New client" or "New reseller"

    Help!! :(
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Have you loaded the ISPConfig database dump manually into the database?
     
  3. crapufish

    crapufish New Member

    Umh... no... do I have to?

    The database seems correctly created, all the tables seems to be in place. I can login, i can install new add-ons, change password etc. I just cannot create a new client, reseller and hosting plan ...
     
    Last edited: Mar 13, 2007
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    No. The installer must install the database for you.

    Did you notice any errors during the ISPConfig installation?
    Any errors in /home/admispconfig/ispconfig/ispconfig.log?

    Did you modify the ISPConfig sources or the database?
     
  5. crapufish

    crapufish New Member

    No, i didn't noticed any error....

    Here is the log:

    Code:
    13.03.2007 - 00:39:44 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/apache2 restart &> /dev/null
    13.03.2007 - 00:39:44 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/postfix stop &> /dev/null
    13.03.2007 - 00:39:45 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/postfix start &> /dev/null
    13.03.2007 - 00:39:48 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/bind9 restart &> /dev/null
    13.03.2007 - 00:39:50 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/proftpd restart &> /dev/null
    13.03.2007 - 00:40:15 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:42:01 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:42:02 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:42:03 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:42:05 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:42:25 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:42:27 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:42:37 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:48:59 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:49:00 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:49:28 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:49:29 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:49:30 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:49:49 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/apache2 restart &> /dev/null
    13.03.2007 - 00:49:49 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/postfix stop &> /dev/null
    13.03.2007 - 00:49:50 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/postfix start &> /dev/null
    13.03.2007 - 00:49:52 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/bind9 restart &> /dev/null
    13.03.2007 - 00:49:55 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/proftpd restart &> /dev/null
    13.03.2007 - 00:54:35 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:54:36 => DEBUG - The requested document type does not exist.
    13.03.2007 - 00:54:38 => DEBUG - The requested document type does not exist.
    13.03.2007 - 01:11:45 => DEBUG - The requested document type does not exist.
    13.03.2007 - 01:12:03 => DEBUG - The requested document type does not exist.
    13.03.2007 - 01:12:04 => DEBUG - The requested document type does not exist.
    13.03.2007 - 01:12:05 => DEBUG - The requested document type does not exist.
    13.03.2007 - 01:13:45 => DEBUG - The requested document type does not exist.
    13.03.2007 - 01:31:28 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/apache2 restart &> /dev/null
    13.03.2007 - 01:31:29 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/postfix stop &> /dev/null
    13.03.2007 - 01:31:29 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/postfix start &> /dev/null
    13.03.2007 - 01:31:32 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/bind9 restart &> /dev/null
    13.03.2007 - 01:31:34 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/proftpd restart &> /dev/null
    13.03.2007 - 01:40:52 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/apache2 restart &> /dev/null
    13.03.2007 - 01:40:53 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/postfix stop &> /dev/null
    13.03.2007 - 01:40:53 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/postfix start &> /dev/null
    13.03.2007 - 01:40:56 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/bind9 restart &> /dev/null
    13.03.2007 - 01:40:58 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/proftpd restart &> /dev/null
    13.03.2007 - 01:49:54 => DEBUG - The requested document type does not exist.
    13.03.2007 - 08:28:46 => DEBUG - The requested document type does not exist.
    13.03.2007 - 08:39:42 => DEBUG - <center>Installation OK</center>
    13.03.2007 - 08:41:02 => DEBUG - <center>Installation OK</center>
    13.03.2007 - 08:46:20 => DEBUG - The requested document type does not exist.
    13.03.2007 - 08:46:30 => DEBUG - The requested document type does not exist.
    13.03.2007 - 08:46:31 => DEBUG - The requested document type does not exist.
    13.03.2007 - 08:46:36 => DEBUG - The requested document type does not exist.
    13.03.2007 - 08:46:37 => DEBUG - The requested document type does not exist.
    13.03.2007 - 08:48:57 => DEBUG - The requested document type does not exist.
    13.03.2007 - 20:23:31 => DEBUG - The requested document type does not exist.
    13.03.2007 - 20:23:34 => DEBUG - The requested document type does not exist.
    13.03.2007 - 20:24:35 => DEBUG - The requested document type does not exist.
    13.03.2007 - 20:24:41 => DEBUG - The requested document type does not exist.
    13.03.2007 - 20:25:40 => DEBUG - The requested document type does not exist.
    13.03.2007 - 20:25:45 => DEBUG - The requested document type does not exist.
    13.03.2007 - 20:26:57 => DEBUG - The requested document type does not exist.
    13.03.2007 - 20:28:32 => DEBUG - The requested document type does not exist.
    Nope :( I installed ISPConfig twice, standard instalation, no expert mode...

    I just have no idea what it might be wrong....


    Help!!

    THANKS!!!
     
  6. crapufish

    crapufish New Member

    Actions which doesn't work

    Here are all the actions (I discovered) which does not work:
    ISP Manager: New reseller, New client, Hostingplan
    DNS Manager:New Master, New Slave
    ISP invoice: New item, Create Invoice

    It seems all other features/actions are working...

    Rings any bells?

    Thanks!

    Dorian
     
  7. crapufish

    crapufish New Member

    Might this be the cause of this probmem?

    It appears when I am trying to restart ISPConfig...

    Code:
    # /etc/init.d/ispconfig_server restart
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Shutting down ISPConfig system...
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    /root/ispconfig/httpd/bin/apachectl stop: httpd stopped
    ISPConfig system stopped!
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting ISPConfig system...
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    ISPConfig system is now up and running!
    
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Are you really sure that you did install ISPConfig 2.2.11 and not a SVN or development version? The doctype errors occur when your ISPConfig database is not installed correctly. Please check that the doctype table is not empty.
     
  9. crapufish

    crapufish New Member

    Hi!

    I installed last night the latest Beta version hoping that the error might be fixed ... Unfortulately there is exactly the same problem. The setup went smoothly, but...

    Below is the content of the doctype table (not all columns were selected). This is the 2.3.1-dev version, but, I am pretty sure that this table was populated correctly in 2.2.11 too.

    I will remove this beta version and install 2.2.11 again.

    I installed my OS (Ubuntu 6.10) following step by step all the instructions in the "Perfect Setup".

    Thanks!!

    Dorian


    Code:
    mysql> SELECT  doctype_id,userid,groupid,doctype_modul,doctype_name,doctype_title FROM doctype;
    +------------+--------+---------+---------------+------------------+-------------------+
    | doctype_id | userid | groupid | doctype_modul | doctype_name     | doctype_title     |
    +------------+--------+---------+---------------+------------------+-------------------+
    |          3 |      1 |       1 | sys           | news             | News              |
    |          1 |      1 |       1 | sys           | user             | User Manager      |
    |       1000 |      1 |       0 |               | dummy            | dummy             |
    |         10 |      1 |       0 | help          | documents        | Online Hilfe      |
    |          2 |      1 |       0 | sys           | modules          | Modul Manager     |
    |       1010 |      1 |       1 | sys           | server           | ISP Server        |
    |       1011 |      1 |       1 | isp           | isp_actions      | ISP Aktionen      |
    |       1012 |      1 |       0 | isp           | isp_kunde        | ISP Kunde         |
    |       1013 |      1 |       0 | isp           | isp_web          | ISP Web           |
    |       1014 |      1 |       0 | isp           | isp_user         | ISP User          |
    |       1015 |      1 |       1 | isp           | isp_domain       | ISP Domain        |
    |       1016 |      1 |       0 | dns           | isp_dns          | DNS Eintrag       |
    |       1019 |      1 |       0 | dns           | cname            | CNAME Record      |
    |       1018 |      1 |       0 | dns           | a                | A Record          |
    |       1020 |      1 |       0 | dns           | mx               | MX Record         |
    |       1021 |      1 |       1 | sys           | serverstatus     | ISP Server Status |
    |       1022 |      1 |       1 | isp           | isp_reseller     | ISP Anbieter      |
    |       1023 |      1 |       1 | sys           | dienste          | ISP Dienste       |
    |       1024 |      1 |       1 | sys           | monitor          | ISP               |
    |       1025 |      1 |       1 | sys           | firewall         | ISP Firewall      |
    |       1026 |      1 |       1 | isp_fakt      | artikel          | Artikel           |
    |       1027 |      1 |       1 | sys           | config           | System Config     |
    |       1028 |      1 |       0 | dns           | secondary        | Slave Zone        |
    |       1029 |      1 |       0 | isp           | isp_datenbank    | ISP Datenbank     |
    |       1030 |      1 |       0 | isp           | isp_web_template | ISP Web-Vorlage   |
    |       1031 |      1 |       0 | dns           | spf              | SPF Record        |
    +------------+--------+---------+---------------+------------------+-------------------+
    26 rows in set (0.00 sec)
    
    
     
  10. crapufish

    crapufish New Member

    Any ideas?

    I think I'll give up... :(

    Thanks!
     
  11. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please reinstall the stable version.
     
  12. crapufish

    crapufish New Member

    Yap, did it :)
    I am on stable version again
     
  13. crapufish

    crapufish New Member

    I guess I'll quit trying....

    I reinstalled linux, downgrading to Ubuntu 6.06 Server (following the perfect setup, of course).
    Guess what... SAME ERROR!

    Of course, no obvious errors during setup... Database is in place, tables seems to be ok....

    I guess ISPConfig is just not for me....
     
  14. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Gow did you unpack the installer tar.gz, on your server or did you unpack it on your workstation and the upload the files to your server?
     
  15. crapufish

    crapufish New Member

    Unpacked on server...
     
  16. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    That's really strange, I regularily install ISPConfig on Ubuntu and other linux distributions and never had this problem. The problem must be related to the database table doctype. Either it is empty or the data in it is corrupted so ISPÜConfig is not able to unserialize the data.

    Which locales do you have on your server configured?
     
  17. crapufish

    crapufish New Member

    Not sure... how should I find this out?
    During setup, I "forced" mysql to use UTF-8 as default encoding... Could this be a problem?

    Thanks!
     
  18. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Yes, this might be the problem. ISPConfig does not support UTF-8, the tables must be in Latin1.
     
  19. crapufish

    crapufish New Member

    I am trying to convert the tables to Latin1... Let's see what happens...
     
  20. crapufish

    crapufish New Member

    Nope, that's not it.... Converted everything to Latin1 and it still doesn't work...
    Peraps I should reinstall ISPConfig (for the 100 th time...)?

    And, here are the locales:

    Code:
    # locale
    LANG=en_US.UTF-8
    LANGUAGE=en_RO:en
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=
    
     

Share This Page