Cannot creat user

Discussion in 'Installation/Configuration' started by fofan, Jul 27, 2006.

  1. fofan

    fofan New Member

  2. egbringas

    egbringas New Member

    same here...it seems that somehow when deleting users doesn't show in the panel anymore but it is in the database...e.g. sys_user table...will it work/safe by just removing them directly in the database?

    but this problem aside, i can say that my install is working well....after a couple of install/uninstall...i finally nailed it...
     
  3. punto

    punto New Member

    Try emptying the recycle bin, I had this issue with a domain.

    Matt
     
  4. egbringas

    egbringas New Member

    aha! that worked!!! thanks!
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Never remove anything from the database manually if you dont want to mess up your ISPConfig installation!
     
  6. learning

    learning New Member

    Same Problem

    Till,

    Very true, don't mess with the databases outside of ISPConfig. BUT, I have the same problem as the other guy.

    I Un-installed / Re-installed having deleted EVERYTHING pertaining to the program. Now all my sites are up and working BUT, I cannot create my mail users. I need to use the same usernames as previous installation. I already searched my drive for that user, NADA. I cleared out an already emtpy Recycle Bin, NADA. Now what? go to my database (look above). Please inform me of the procedure.

    Thank you,

    Richard

    BTW: the user entry is not in the sys_user table, I already looked.
     
    Last edited: Dec 1, 2006
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    This is problem is caused by a security mechanism in ISPConfig, which prevents the creation of users in ISPConfig that existed at the time you installed ISPConfig. This function is to protect users like www-data or postfix and even the root user to get modified by ISPConfig and in your case, the system users created by your first ISPConfig instalation where blacklisted too.

    Please remove the usernames from the file:

    /home/admispconfig/ispconfig/users

    and you will be able to create these users in ISPConfig again.
     

Share This Page