Cannot contect to mail server

Discussion in 'Server Operation' started by tommytomato, Sep 25, 2006.

  1. tommytomato

    tommytomato New Member

    Hi all

    I've been following this link for some time now and I've findly got it going.
    http://www.howtoforge.com/virtual_postfix_mysql_quota_courier

    how ever if I use outlook express to contect to the mail server I get error after error.

    sending mail from outlook express to an account on the mail server works.
    replying back to outlook from mail server works

    email an outside account like hotmail works and replying works as well

    I'm using mutt

    but for the life of me I cant get Outlook setting to work to be able to use it as a mail client.

    any idea please.

    TT
     
    Last edited: Sep 25, 2006
  2. tommytomato

    tommytomato New Member

    Here is the error I'm getting, can any one help me out please.

    I'm unsure were to look to correct the prolbem

    TT

    P.S opps can some move this topic to the right area, I've only just notice it was in the wrong area, sorry

    out_look_error.jpg
     
    Last edited: Sep 26, 2006
  3. sjau

    sjau Local Meanie Moderator

    What are your connection settings?
    What user do you try to login as username?
     
  4. tommytomato

    tommytomato New Member

    can you explain what you mean by connection settings please

    I'm using the user I added via the command line, Or should I add a user uing mysql :confused:

    TT
     
  5. falko

    falko Super Moderator ISPConfig Developer

    In your email client, do you use the server's IP address or a FQDN? Try the IP address for now to rule out DNS problems.
    What's the output of
    Code:
    netstat -tap
    on your server? Is port 110 open in the firewall?
     
  6. tommytomato

    tommytomato New Member

    Yes I have tried the IP address of the PC box in question, I'm unsure about the firewall, I was wondering the same thing weather the box was allowing me in to check mail. I know I have the ports open on my router which are ( 25, 100 )


    netstat -tap give's me

    Code:
    netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State                                                     PID/Program name
    tcp        0      0 *:imaps                 *:*                     LISTEN     1                                              121/couriertcpd
    tcp        0      0 *:pop3s                 *:*                     LISTEN     1                                              144/couriertcpd
    tcp        0      0 *:743                   *:*                     LISTEN     1                                              409/rpc.statd
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN     1                                              040/amavisd (maste
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN     1                                              352/master
    tcp        0      0 localhost.localdo:mysql *:*                     LISTEN     1                                              216/mysqld
    tcp        0      0 *:pop3                  *:*                     LISTEN     1                                              130/couriertcpd
    tcp        0      0 *:imap2                 *:*                     LISTEN     1                                              107/couriertcpd
    tcp        0      0 *:sunrpc                *:*                     LISTEN     8                                              56/portmap
    tcp        0      0 *:www                   *:*                     LISTEN     1                                              428/apache
    tcp        0      0 *:auth                  *:*                     LISTEN     1                                              160/inetd
    tcp        0      0 *:ssh                   *:*                     LISTEN     1                                              404/sshd
    tcp        0      0 *:smtp                  *:*                     LISTEN     1                                              352/master
    tcp        0      0 rockinghamgateway.c:ssh 192.168.1.7:3605        ESTABLISHED1                                              457/sshd: [email protected]
    tcp        0      0 localhost.localdo:mysql localhost.localdom:1034 ESTABLISHED1                                              216/mysqld
    tcp        0      0 localhost.localdo:mysql localhost.localdom:1035 ESTABLISHED1                                              216/mysqld
    tcp        0      0 rockinghamgateway.c:ssh 192.168.1.7:3659        ESTABLISHED1                                              475/0
    tcp        0      0 localhost.localdom:1034 localhost.localdo:mysql ESTABLISHED1                                              425/amavisd (child
    tcp        0      0 localhost.localdom:1035 localhost.localdo:mysql ESTABLISHED1                                              424/amavisd (child
    tcp        0      0 localhost.localdom:1052 localhost.localdo:mysql TIME_WAIT  -                                              
    tcp        0      0 localhost.localdom:1053 localhost.localdo:mysql TIME_WAIT  -                                              
    rockinghamgateway:~#
    
    TT
     
  7. tommytomato

    tommytomato New Member

    this has me foxed big time right now

    I'm reinstalling the server using a netinstall CD

    here is one of the errors I get

    some times i get the login box, username and password

    as if I have the wrong details in, if you get my drift

    [​IMG]

    these two are from my Linux FC5

    [​IMG]

    [​IMG]
     
  8. tommytomato

    tommytomato New Member

    I've redone this and I get the same problem

    able to send and recive mail from local and remote using PuTTY to PC using mutt only

    unable to use email cleints from XP or FC5

    can any one help me work this out please.

    TT
     
  9. falko

    falko Super Moderator ISPConfig Developer

    I get timeouts when I try to connect to your server:

    Code:
    mh1:~# telnet rockinghamgateway.com 25
    Trying 58.7.0.171...
    
    mh1:~# telnet rockinghamgateway.com 110
    Trying 58.7.0.171...
    Is 58.7.0.171 the correct IP address? Please check the firewall and your router to make sure ports 25 and 110 are allowed.
     
  10. tommytomato

    tommytomato New Member

    Yes thats the correct IP address, I shut down the box while I go off for a sleep.

    TT
     
  11. tommytomato

    tommytomato New Member

    I'll leave it on this time so you can have a look

    TT
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Now it's working:

    Code:
    mh1:~# telnet rockinghamgateway.com 25
    Trying 58.7.0.171...
    Connected to dsl-58-7-0-171.wa.westnet.com.au.
    Escape character is '^]'.
    220 rockinghamgateway.com ESMTP Postfix (Debian/GNU)
    ehlo localhost
    250-rockinghamgateway.com
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH LOGIN PLAIN
    250-AUTH=LOGIN PLAIN
    250 8BITMIME
    quit
    221 Bye
    Connection closed by foreign host.
    mh1:~# telnet rockinghamgateway.com 110
    Trying 58.7.0.171...
    Connected to dsl-58-7-0-171.wa.westnet.com.au.
    Escape character is '^]'.
    +OK Hello there.
    quit
    +OK Better luck next time.
    Connection closed by foreign host.
    mh1:~#
     
  13. tommytomato

    tommytomato New Member

    Good to see you got in ok

    But how do we use another email client to conntect to the email server to read mail ?

    TT
     
  14. falko

    falko Super Moderator ISPConfig Developer

    You can use any email client (Outlook, Thunderbird, ...). Use rockinghamgateway.com as SMTP and POP3 server, and don't forget to enable "Server requires authentication." because otherwise you'll get "Relay access denied" or something like that when you try to send mails.
     
  15. tommytomato

    tommytomato New Member

    falko

    I've tried all that, I've even download Thunderbird to try that out

    [​IMG]

    I've reinstalled this again, this time I've add the user into the MySQL databse and not via the command line.

    I still get can not conntect using Outlook and Thunderbird :(

    [​IMG]

    TT
     
  16. falko

    falko Super Moderator ISPConfig Developer

    What happens in your mail log when you try to fetch mails? And why does the error message mention a proxy? :confused: Are you connecting directly to your server, or over some kind of proxy?
     
  17. tommytomato

    tommytomato New Member

    Dont know any thing about the proxy as far as I know I dont conntect through a proxy. how do I tell :confused: Yes as far as I know I am conntecting directly to the web server.

    last error I get is this which is from outlook express
    Code:
    The connection to the server has failed. Account: 'rockinghamgateway.com', Server: 'rockinghamgateway.com', Protocol: POP3, Port: 110, Secure(SSL): No, Socket Error: 10061, Error Number: 0x800CCC0E
    Non of my logs are showing any thing conntecting from my PC that I'm using to check mail using Outlook Express

    only log I can think of is this one, but my system time is out.

    Code:
    Oct  2 18:12:57 localhost dccproc[1481]: socket(UDP): Address family not supported by protocol
    Oct  2 18:13:00 localhost dccproc[1488]: socket(UDP): Address family not supported by protocol
    
    TT
     
  18. tommytomato

    tommytomato New Member

    If i use my the email server IP in the outlook mail settings I found this error in my logs

    Code:
    Oct  2 18:29:01 localhost courierpop3login: Connection, ip=[::ffff:192.168.1.7]
    Oct  2 18:29:06 localhost courierpop3login: LOGIN FAILED, ip=[::ffff:192.168.1.7]
    Oct  2 18:29:19 localhost courierpop3login: Connection, ip=[::ffff:192.168.1.7]
    Oct  2 18:29:24 localhost courierpop3login: LOGIN FAILED, ip=[::ffff:192.168.1.7]
    tried a few settings to recive this

    Code:
    Oct  2 18:36:59 localhost postfix/smtpd[1541]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Oct  2 18:36:59 localhost postfix/smtpd[1541]: warning: unknown[192.168.1.7]: SASL LOGIN authentication failed
    Oct  2 18:36:59 localhost postfix/smtpd[1541]: lost connection after AUTH from unknown[192.168.1.7]
    Oct  2 18:36:59 localhost postfix/smtpd[1541]: disconnect from unknown[192.168.1.7]


    TT
     
    Last edited: Oct 2, 2006
  19. tommytomato

    tommytomato New Member

    Ok we worked out that we can send mail using Outlook but we cant recive mail using outlook yet.

    we had to tick a box under properties - advanced

    [​IMG]

    error given off by Outlook when checking email account, its saying password was rejected, I have re type my password and even created new accounts still get the same error below

    Code:
    There was a problem logging onto your mail server. Your Password was rejected. Account: '192.168.1.3', Server: '192.168.1.3', Protocol: POP3, Server Response: '-ERR Login failed.', Port: 110, Secure(SSL): No, Server Error: 0x800CCC90, Error Number: 0x800CCC92
    also how do we get it to read rockinghamgatewaygateway.com instead of the machines IP

    TT
     
    Last edited: Oct 2, 2006
  20. tommytomato

    tommytomato New Member

    Still having the same error here guys

    There was a problem logging onto your mail server. Your Password was rejected. Account: '192.168.1.3', Server: '192.168.1.3', Protocol: POP3, Server Response: '-ERR Login failed.', Port: 110, Secure(SSL): No, Server Error: 0x800CCC90, Error Number: 0x800CCC92

    any idea's please.

    I've gone over every thing 3 or 4 time's.

    how would this tutorial that so many people have been following work on a tiny sofa system :confused: , just scored my 200gig hard drive, So i'll have to do a reboot on the main server soon

    TT
     

Share This Page