cannot connect to SSL

Discussion in 'Installation/Configuration' started by pattyjay, Nov 10, 2009.

  1. pattyjay

    pattyjay New Member

    hey people,

    ive racked my brain over this one! i have enabled SSL for a site and in the SSL tab i have created a certificate, which upon loggin out and back in the settings are still there, however cannot connect to https://mydomain.com.au

    amnything else i need to do?


    :confused::confused:

    i have restarted the server and stillnothing... also i have tried it on multiple domains, not just the one.... and i cannot connect at all
     
    Last edited: Nov 10, 2009
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which error message do you get in the web browser?
     
  3. pattyjay

    pattyjay New Member

    in ie i get :

    Internet Explorer cannot display the webpage

    What you can try:
    Diagnose Connection Problems


    in fireforx i get:

    This webpage is not available.

    The webpage at https://mydomain.com.au might be temp down or it may have have moved permanentkyto a new web address

    + more info

    ERROR 102 (net::ERR_CONNECTION_REFUSED): Unknown error.


    so confused.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ?
    Are there any errors in that web site's error log?
     
  5. pattyjay

    pattyjay New Member


    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
    tcp        0      0 *:mysql                     *:*                         LISTEN      15634/mysqld
    tcp        0      0 *:hosts2-ns                 *:*                         LISTEN      7655/ispconfig_http
    tcp        0      0 *:ftp                       *:*                         LISTEN      22117/proftpd: (acc
    tcp        0      0 xxxx.mydomain.com.au:domain *:*                         LISTEN      9232/named
    tcp        0      0 localhost.localdomai:domain *:*                         LISTEN      9232/named
    tcp        0      0 *:smtp                      *:*                         LISTEN      13862/smtpd
    tcp        0      0 localhost.localdomain:rndc  *:*                         LISTEN      9232/named
    tcp        0      0 *:pop3                      *:*                         LISTEN      15694/dovecot
    tcp        0      0 *:imap                      *:*                         LISTEN      15694/dovecot
    tcp        0      0 *:http                      *:*                         LISTEN      7746/httpd
    tcp        0      0 *:ssh                       *:*                         LISTEN      15500/sshd
    tcp        0      0 ::1:rndc                    *:*                         LISTEN      9232/named
    tcp        0      0 *:imaps                     *:*                         LISTEN      15694/dovecot
    tcp        0      0 *:pop3s                     *:*                         LISTEN      15694/dovecot
    tcp        0   1036 xxxx.mydomain.com.au:ssh  CPE-xx-xxx-xxx-xxx.cj:49181 ESTABLISHED 11960/sshd: [email protected]
    
    
    in relation to the error log, there is a little bit or error logs that are only relevant to june this year in relation to a client trying to access a file that doesnt exist....
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Your Apache isn't listening on port 443. Can you check your Apache configuration if you have
    Code:
    Listen 443
    somewhere?
     
  7. pattyjay

    pattyjay New Member

    i checked

    /etc/httpd/conf/httpd.conf

    i couldnt find it, the only thing i could find was

    listen 80,obviously for standard http

    i also checked

    /root/ispconfig/httpd/conf/httpd.conf

    and it wasnt in there either
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Please add
    Code:
    Listen 443
    below
    Code:
    Listen 80
    in /etc/httpd/conf/httpd.conf and restart Apache.
     
  9. pattyjay

    pattyjay New Member

  10. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use? Which guide (URL) did you use to set it up?
     
  11. pattyjay

    pattyjay New Member

Share This Page