Cannot connect to ispconfig

Discussion in 'Installation/Configuration' started by JamesShijie, Jul 3, 2010.

  1. JamesShijie

    JamesShijie New Member

    Hi there,

    I scoured the forums looking for an answer to my quandry, and couldn't find one. I install ispconfig 3.2.2 without a hitch, and when I go to connect to it server.example.com:8080, it stalls and times out. Here's what I found out so far:

    After installation, I somehow have no:
    Code:
    /root/ispconfig
    /home/adminispconfig/
    /etc/init.d/ispconfig_server
    
    It looks like SOMETHING is listening on port 8080:
    Code:
    Not shown: 1667 closed ports
    PORT     STATE SERVICE
    21/tcp   open  ftp
    22/tcp   open  ssh
    25/tcp   open  smtp
    80/tcp   open  http
    110/tcp  open  pop3
    111/tcp  open  rpcbind
    143/tcp  open  imap
    669/tcp  open  unknown
    993/tcp  open  imaps
    995/tcp  open  pop3s
    3306/tcp open  mysql
    8080/tcp open  http-proxy
    8081/tcp open  blackice-icecap
    The mysql database "dbispconfig" is created, and I can see when I do a query. I can get to my server via the web, /etc/hosts looks like:
    Code:
    # 'hosts' file configuration.
    127.0.0.1       china.mingtiandi.com.local      localhost
    172.20.6.84     china.mingtiandi.com    china
    ::ffff:172.20.6.84      china.mingtiandi.com    china
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    
    I can also get to phpmyadmin. But the install script doesn't complete, and I cannot connect on port 8080. If you need anything posted, let me know! Thanks!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    These directories are used by ISPConfig 2, but not 3, so this is absolutely ok.

    What's the output of
    Code:
    netstat -tap
    ?
     
  3. JamesShijie

    JamesShijie New Member

    Hi, thanks for your reply.

    My output is as thus:
    Code:
    [[email protected] ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
    tcp        0      0 *:imaps                     *:*                         LISTEN      11679/dovecot       
    tcp        0      0 *:pop3s                     *:*                         LISTEN      8870/pop3-login     
    tcp        0      0 china.mingtiandi.com.:10024 *:*                         LISTEN      11667/amavisd (mast 
    tcp        0      0 china.mingtiandi.com.:10025 *:*                         LISTEN      11607/master        
    tcp        0      0 *:mysql                     *:*                         LISTEN      11536/mysqld        
    tcp        0      0 *:pop3                      *:*                         LISTEN      8870/pop3-login     
    tcp        0      0 china.mingtiand:dyna-access *:*                         LISTEN      24645/clamd         
    tcp        0      0 *:imap                      *:*                         LISTEN      11679/dovecot       
    tcp        0      0 *:sunrpc                    *:*                         LISTEN      2568/portmap        
    tcp        0      0 china.mingtiandi.com:domain *:*                         LISTEN      11781/named         
    tcp        0      0 *:ftp                       *:*                         LISTEN      3221/vsftpd         
    tcp        0      0 china.mingtiandi.com.lo:ipp *:*                         LISTEN      3183/cupsd          
    tcp        0      0 china.mingtiandi.com.l:rndc *:*                         LISTEN      11781/named         
    tcp        0      0 *:smtp                      *:*                         LISTEN      11607/master        
    tcp        0      0 *:meregister                *:*                         LISTEN      2607/rpc.statd      
    tcp        0      0 china.mingtiandi.com.:mysql china.mingtiandi.com.:42274 ESTABLISHED 11536/mysqld        
    tcp        0      0 china.mingtiandi.com.:41970 china.mingtiandi.com.:mysql ESTABLISHED 11792/amavisd (ch4- 
    tcp        0      0 china.mingtiandi.com.:42274 china.mingtiandi.com.:mysql ESTABLISHED 11791/amavisd (ch4- 
    tcp        0      0 china.mingtiandi.com.:mysql china.mingtiandi.com.:41970 ESTABLISHED 11536/mysqld        
    tcp        0      0 *:imaps                     *:*                         LISTEN      11679/dovecot       
    tcp        0      0 *:pop3s                     *:*                         LISTEN      8870/pop3-login     
    tcp        0      0 *:pop3                      *:*                         LISTEN      8870/pop3-login     
    tcp        0      0 *:imap                      *:*                         LISTEN      11679/dovecot       
    tcp        0      0 *:webcache                  *:*                         LISTEN      11701/httpd         
    tcp        0      0 *:http                      *:*                         LISTEN      11701/httpd         
    tcp        0      0 *:tproxy                    *:*                         LISTEN      11701/httpd         
    tcp        0      0 ip6-localhost:domain        *:*                         LISTEN      11781/named         
    tcp        0      0 *:ssh                       *:*                         LISTEN      3169/sshd           
    tcp        0      0 ip6-localhost:rndc          *:*                         LISTEN      11781/named         
    tcp        0   2960 china.mingtiandi.com:ssh    host.mingtiandi.com:43650   ESTABLISHED 13896/0             
    
     
  4. Nimarda

    Nimarda New Member

    Hi,

    I had the same problem. What i did is restart the firewall.
    I dont know if you have the same, but this did help me.

    /etc/init.d/bastille-firewall restart

    By the way,
    How can i do this automaticly on a new reboot?
    Because after a reboot, the server doesnt restart the firewall.
     
  5. JamesShijie

    JamesShijie New Member

    still no

    Hi,

    Thanks very much for the help and reply. Unfortunately it still doesn't work. This is what happened:

    Code:
    [[email protected] ~]# /etc/init.d/bastille-firewall restart
    Setting up IP spoofing protection... done.
    Allowing traffic from trusted interfaces... done. 
    Setting up chains for public/internal interface traffic... done. 
    Setting up general rules... done.
    Setting up outbound rules... done.
    
    So it looks like it restarted, but In firefox, it just says "connecting" but never connects, and just times out. Here's what happens when I telnet to both port 80, and 8080:

    Code:
    -bash-3.2$ telnet china.mingtiandi.com 80
    Trying 210.51.55.153...
    Connected to china.mingtiandi.com (210.51.55.153).
    Code:
    Connection closed by foreign host.
    -bash-3.2$ telnet china.mingtiandi.com 8080
    Trying 210.51.55.153...
    
    And it just hangs there indefinitely. Gaahhh is there anything else I can check??
     
  6. Nimarda

    Nimarda New Member

    Did you have port 8080 enabled in your firewall?

    Stop firewall and check if you can access!
    /etc/init.d/bastille-firewall stop

    if you can connect then, add this to ispconfig firewall:
    TCP
    20,21,22,25,53,80,110,143,443,3306,8080,10000

    UDP
    53,3306
     
    Last edited: Jul 5, 2010
  7. JamesShijie

    JamesShijie New Member

    I did that, and still can't connect :(
    Code:
    [[email protected] ~]# /etc/init.d/bastille-firewall stop
    
    WARNING: reverting to default settings (dropping firewall)
    disabling IP forwarding... done.
    unloading masquerading modules... done.
    resetting default input rules to accept... done.
    resetting default output rule to accept... done.
    resetting default forward rule to accept... done.
    flushing INPUT rules... done.
    flushing OUTPUT rules... done.
    flushing FORWARD rules... done.
    removing user-defined chains...iptables: No chain/target/match by that name
    iptables: No chain/target/match by that name
    iptables: No chain/target/match by that name
    iptables: No chain/target/match by that name
    iptables: No chain/target/match by that name
    iptables: No chain/target/match by that name
    iptables: No chain/target/match by that name
    iptables: No chain/target/match by that name
    iptables: No chain/target/match by that name
    iptables: No chain/target/match by that name
     done.
    
    I've stopped iptables as well. I don't have any other firewalls. What else would be blocking that port, or is it installed incorrectly? Let me know how to check.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    please post the output of the command:

    netstat -tap


    and

    iptables -L


    from where do you connect? A local network or from external trogh a router?
     
  9. JamesShijie

    JamesShijie New Member

    Code:
    [[email protected] ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
    tcp        0      0 *:imaps                     *:*                         LISTEN      11440/imap-login
    tcp        0      0 *:pop3s                     *:*                         LISTEN      11679/dovecot
    tcp        0      0 china.mingtiandi.com.:10024 *:*                         LISTEN      11667/amavisd (mast
    tcp        0      0 china.mingtiandi.com.:10025 *:*                         LISTEN      11607/master
    tcp        0      0 *:mysql                     *:*                         LISTEN      11536/mysqld
    tcp        0      0 *:pop3                      *:*                         LISTEN      11679/dovecot
    tcp        0      0 china.mingtiand:dyna-access *:*                         LISTEN      24645/clamd
    tcp        0      0 *:imap                      *:*                         LISTEN      11440/imap-login
    tcp        0      0 *:sunrpc                    *:*                         LISTEN      2568/portmap
    tcp        0      0 china.mingtiandi.com:domain *:*                         LISTEN      11781/named
    tcp        0      0 *:ftp                       *:*                         LISTEN      3221/vsftpd
    tcp        0      0 china.mingtiandi.com.lo:ipp *:*                         LISTEN      3183/cupsd
    tcp        0      0 china.mingtiandi.com.l:rndc *:*                         LISTEN      11781/named
    tcp        0      0 *:smtp                      *:*                         LISTEN      11607/master
    tcp        0      0 *:meregister                *:*                         LISTEN      2607/rpc.statd
    tcp        0      0 *:imaps                     *:*                         LISTEN      11440/imap-login
    tcp        0      0 *:pop3s                     *:*                         LISTEN      11679/dovecot
    tcp        0      0 *:pop3                      *:*                         LISTEN      11679/dovecot
    tcp        0      0 *:imap                      *:*                         LISTEN      11440/imap-login
    tcp        0      0 *:webcache                  *:*                         LISTEN      13600/httpd
    tcp        0      0 *:http                      *:*                         LISTEN      13600/httpd
    tcp        0      0 *:tproxy                    *:*                         LISTEN      13600/httpd
    tcp        0      0 ip6-localhost:domain        *:*                         LISTEN      11781/named
    tcp        0      0 *:ssh                       *:*                         LISTEN      3169/sshd
    tcp        0      0 ip6-localhost:rndc          *:*                         LISTEN      11781/named
    tcp        0      0 china.mingtiandi.com:ssh    122-146-188-203.stati:38786 ESTABLISHED 23914/sshd: unknown
    tcp        0      0 china.mingtiandi.com:ssh    ::ffff:114.94.165.93:13347  ESTABLISHED 13418/0
    getnameinfo failed
    tcp        0   2520 china.mingtiandi.com:ssh    [UNKNOWN]:seaview           ESTABLISHED 23867/1
    
    Code:
    [[email protected] ~]# iptables -L
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    
    The server I'm connecting to is an external server, not on my local network. You can try it for yourself and see if you get anything:

    Code:
    china.mingtiandi.com:8080
    It's a new installation, but I know DNS resolves, phpmyadmin works, and squirrelmail works too. you can also take a look at my phpinfo page at china.mingtiandi.com/info.php if that helps. Thanks!
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Does the router forward port 8080 to your ISPConfig server?
     
  11. JamesShijie

    JamesShijie New Member

    I have forwarded on my router at home, and still cannot connect. Try telnetting to it from ANYWHERE, even if 8080 is open on that server or intranet. It still won't work

    Code:
    telnet china.mingtiandi.com 8080
    But this works:
    Code:
    telnet china.mingtiandi.com 80
    Is there anything else I can try?
     
  12. JamesShijie

    JamesShijie New Member

    Feeling Sheepish

    Hello,

    Sorry to waste all of your time. It's fixed. At the same time I was configuring the server, I was also getting a vpn running. I forgot I had the vpn running in the background, and so I was connecting via another server that had port 8080 blocked. So that's why it wasn't working. Yep, feeling pretty stupid right now.. Thanks for all your help.
     
  13. Aradan

    Aradan New Member

    EDIT:
    I just posted to late as I see you have solved the problem now.. I will leave the below info there incase it helps someone else.

    ====

    Hi there,

    I know this is a long shot but, this actually worked for me when I encountered a similar problem as yourself.

    Just try restarting httpd;

    Code:
    /etc/init.d/httpd restart
    Hope this helps, simple but for some reason (what ever it maybe - I didn't look too much into why it didnt work at first) it worked for me.

    Cheers,
    -Aradan
     
    Last edited: Jul 7, 2010

Share This Page