Cannot connect to ftp 530 Login authentication failed

Discussion in 'ISPConfig 3 Priority Support' started by gpetrom, Oct 3, 2019.

  1. gpetrom

    gpetrom Member HowtoForge Supporter

    ISPConfig Version: 3.1.15
    Debian 9 on 2 servers a) Apache and 2)nginx

    Hello, we are trying to connect to both servers and we get the following error.

    Code:
    Response:    331 User *********** OK. Password required
    Command:    PASS ************
    Response:    530 Login authentication failed
    Error:    Critical error: Could not connect to server
    We have also tried changing passwords and using different clients to login.
    Please advise, thank you.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that you either entered a wrong password or username or that you did not create this user as FTP user in ISPConfig or that you did not install pure-ftpd-mysql as shown in the perfect server tutorials.
     
  3. gpetrom

    gpetrom Member HowtoForge Supporter

    Hi
    Pure ftp is running okay but on the service status is the following

    Code:
    The SQL server seems to be down [Host '127.0.0.1' is not allowed to connect to this MariaDB server]
    Please, let me know how I can correct this. I looked in the ISPconfig but didn't find a way to connect it to localhost and not to 127.0.0.1
     
  4. gpetrom

    gpetrom Member HowtoForge Supporter

    I changed mysql address on the following file /etc/pure-ftpd/db/mysql.conf" , from 127.*** to localhost.
    But what happens on an update? It will probably be overwitten.
    Is there a more proper way to set it, other than changing the above file?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if you disabled networking in your MySQL/MariaDB configuration globally, this needs to be turned on again and then restart the database server. If you want to make a database server unreachable from outside, then close the mysql port in the firewall. Do not turn off networking in mysql.
     
  6. gpetrom

    gpetrom Member HowtoForge Supporter

    This is not the case because we can reach the server from the outside. Networking is on. The root user is allowed to connect from localhost and not from 127.***
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The root user is not used by pure-ftpd. pure-ftpd uses the ispconfig user and the ispconfig. If networking is on, then maynbe your 7etc/hosts file is wrong, it must list 'localhost' for IP 127.0.0.1
     
  8. gpetrom

    gpetrom Member HowtoForge Supporter

    I have checked the hosts file and it is ok.
    Code:
    127.0.0.1       localhost
    192.168.100.240 websrv.domain.com    websrv
    
    # The following lines are desirable for IPv6 capable hosts
    #::1     localhost ip6-localhost ip6-loopback
    #ff02::1 ip6-allnodes
    #ff02::2 ip6-allrouters
    
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Then it should work. Please run:

    grep -r networking /etc/mysql

    to see if networking is really enabled on that server and post the result.
     
  10. gpetrom

    gpetrom Member HowtoForge Supporter

    Code:
    grep -r networking /etc/mysql
    /etc/mysql/mariadb.conf.d/50-server.cnf:# Instead of skip-networking the default is now to listen only on
    
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Hmm, that's ok. Then I don't have an idea at the moment why your server fails to use the localhost IP for login, it works fine here out of the box on my Debian 9 and 10 systems that are installed accoring to perfect server guide. You can make your manual config changes update-safe by placing a modified config file template for the pure ftpd sql file in /usr/local/ispconfig/server/conf-custom/install/. You can find the template in install/tpl/ of the ispconfig tar.gz file.
     
  12. gpetrom

    gpetrom Member HowtoForge Supporter

    In mysql users i see only
    ispconfig localhost
    Is this normal ?
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that's the case on my working systems as well.
     

Share This Page