cannot connect Mail client after IMAP server setup

Discussion in 'HOWTO-Related Questions' started by KCPoole, Apr 6, 2006.

  1. KCPoole

    KCPoole New Member

    Hi all

    I have run through "The Perfect Setup - Debian Sarge (3.1)" and run into a few problems but I think I have got it right now :)

    Might be a bit off topic, but I still cannot find out and is not really covered anywhere that I can find, but ask here in case anyone can help.

    What is the format of the Mail client logins ( Mozilla FireFox), in any of the Mailserver howtos here
    For the one above, unix username works ( i think) but I cannot see the IMAP or POP maildir.
    If I select to view unsigned directories then I can see all dirs in my home dir on the server but cannot see any mail, so must assume I can login OK

    If i do the howto "Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAssassin, ClamAV)", I can login as username@domain and see all mail, but this is overkill for my requirements.

    Suggest that for any of the Howtos, that a section added for any particular client logins required.

    Maybe I amm just a bit dumb at the moment :) or maybe just cannot see straight from too much reading.

    Thanks

    KenP

    ps. Also If i want to restart the howto over again from scratch, Should I just remove all packages and restart, or if I just run apt-get install will it go throught the configs again?
     
  2. falko

    falko Super Moderator

    Which POP3/IMAP daemon did you install? Do you use Maildir or mbox?

    If you run apt-get install again, it will tell you that you already have the newest package installed.
    If you just want to reconfigure an already installed package, run
    Code:
    dpkg-reconfigure <package_name>
    , e.g.
    Code:
    dpkg-reconfigure postfix
     
  3. KCPoole

    KCPoole New Member


    I installed the courier IMAP suite of servers and I am trying to use IMAP with Maildirs.
    If use "username" as the login I get no errors but cannot see any emails, but I can see files in my Homedir/Maildir/new on the server itself.
    If I use "username@domain name" then I get errors in Posfix log and auth.log

    I have seen many posts on the web as to client setup saying to use Maildir, Inbox, INBOX. etc under the advanced settings so I am rather confused!


    ps Thanks for the reconfig tips as I will try again later to see if I missed something
     
  4. KCPoole

    KCPoole New Member

    All Fixed now Thanks

    I reran the install / setup ( including the apt-get statements) and the courier bit wanted to install more packages
    courier-authdemon
    courier-base
    courier-ssl
    liobfam0c102

    I have no idea why they did not get installed first time around, but once completed the server started and I could login with my FFox client using "username" only

    :) all happy now
    just need to install Webmail to get it all happening from outside my own network ( cannot get imap / pop from work)

    Thanks Falko

    is there anythng extra needed to get webmail working? other than installing it?
     
  5. falko

    falko Super Moderator

    Normally not, but that depends on the webmail software. For example, Horde is a nightmare to set up, but if you install ISPConfig, then you can install the ISPConfig webmail package afterwards, and it will work out of the box. :)
     

Share This Page