Cannot build rpm packages

Discussion in 'Server Operation' started by aamakhfudh, Feb 23, 2012.

  1. aamakhfudh

    aamakhfudh New Member

    Hello All :) I'm trying to make an email server using this tutorial :

    http://www.howtoforge.com/perfect-server-centos-6.2-x86_64-with-nginx-ispconfig-3-p4

    I followed that tutorial, but when i try to build rpm packages for maildrop using this command :

    and after the proccess finish, and I run command :

    There is no maildrop packages, it shows only courier-authlib packages

    Is there anyone that can solve my problem ??

    Looking forward to hear from you all
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you check the other directories in the /root/rpmbuild/RPMS directory?
     
  3. aamakhfudh

    aamakhfudh New Member

    Last edited: Mar 5, 2012
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you get any error messages when you tried to build maildrop? Chances are it didn't finish because of some errors.
     
  5. aamakhfudh

    aamakhfudh New Member

    hmm, i'm sorry for being so dull but i don't know how to get the error, i follow the process when build it but i don't understand which one is the error message.

    some websites tell that in the ~/rpm/tmp there is script which are generated to actually build and package the package but i don't have that directory in my server.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    You should see errors in the output of the build process.
     
  7. garywo2000

    garywo2000 New Member

    Did you check the other directories in the /root
     
  8. aamakhfudh

    aamakhfudh New Member

    problem solved

    the problem has solved. when i check again the build process it said that the package are in the /root/rpm/RPMS/i686, sorry if the problem bother you all. thanks a lot guys
     

Share This Page