cannot add users

Discussion in 'Installation/Configuration' started by stanman, Jun 10, 2012.

  1. stanman

    stanman New Member

    In the admin gui, I can add a new user to an existing site, assign a name, an email address, everything.
    However the user cannot logon to receive mail.
    When I look into the /var/www/web10/user path, I can see the existing users.
    The new user doesn't show up. Also in the /etc/passwd there's no sign of the new user, nor is the new user in /etc/group.

    This makes me think the user isn't created on the linux machine.

    To check this, I moved the ispconfig.log to ispconfig_old.log and create a new file (as root). Then when i tried to edit things, I got a permissions error, which led me to the logfile, which was owned by root of course, so I set the permissions.

    This reminded me I had some issues a while a go, with passwd and group being empty, I had to recover the file from a backup an that fixed the problem back then.

    Could it be the admispconfig user doesn't have sufficient rights to add users?
    How can I check that?

    Hope I get an answer soon, as I need to add 10+ users to a site :(

    I tried editing a forward mail address, that isn't saved as well... It keeps forwarding the mail to the old mail address, while the gui says it forwards to another address
    Last edited: Jun 10, 2012
  2. stanman

    stanman New Member

    Solved this...

    Turned out the admispconfig user can't edit /etc/passwd and /etc/group if there's no empty line at the end.... Well... I think so. I restored both files before and probably edited them, removing the last empty line.

    After adding an empty line and running /etc/init.d/ispconfig_server restart I had some more problems (In the admin gui i emptied the recyclebin, which removed several old deleted sites), because apache couldn't get up (cannot open the logfiles of several web[n] sites).

    I then vimmed into /etc/apache2/vhos/Vhosts_ispconfig.conf and deleted the Virtualhosts my /var/apache2/error.log was complainting about.

    Finally after restarting the ispconfig_server again, it ran and all sites are up! Adding a new user is also possible.

    Tonight I'll try to add a new site, to see what happens... If that doesn't work as it should, I'll post back (to myself ;-) ) again.

    I hope this thread will help someone having the same probs i had!

Share This Page