cannot add/change/configure default server

Discussion in 'Installation/Configuration' started by hell, Jan 12, 2007.

  1. hell

    hell New Member

    hi guys

    i followed the howtoforge guides to install centos 4.4 and ispconfig.
    installation of both of them went fine :D

    when i connect to the admin webinterface, under 'management/server', if i want to change the settings of the default 'Server 1', it doesn't seem to save the configuration... am i missing something? whats wrong? :confused:

    without those settings, i cannot set up anything else... :(

    any help? tnx
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you install the mysql dump manually?
     
  3. hell

    hell New Member

    YES! i got an mysql error during ispconfig install, so i was looking for the sql file in the install source and imported it manually into the mysql db.

    it seemed to work fine... (adding users, resellers, etc.)... except for the servers... :(

    shall i drop the tables/database and reinstall ispconfig?

    greetings from switzerland :)
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Importing the SQL dump in ISPConfig does not work, because the data gathered by the setup script is missing in the server settings.

    1) Uninstall ISPConfig:

    /etc/init.d/ispconfig_server stop
    rm -rf /root/ispconfig/
    rm -rf /home/admispconfig

    Then delete the ISPConfig mysql database.

    2) Before you install ISPConfig again, make sure that:

    - no database exists with the name that you enter in the iSPConfig installer.
    - You use a mysql username that has the same priveliges then the mysql root user.
    - the password of the mysql user does not contain any special characters like these: ยง$%&/()"'?^<>|
     
  5. hell

    hell New Member

    worked perfect! many tnx, till!
     

Share This Page