cannot access subdomain homepage

Discussion in 'Installation/Configuration' started by saco721, Oct 14, 2013.

  1. saco721

    saco721 Member HowtoForge Supporter

    I have just finished installing the multi-server setup for ispconfig on debian squeeze. First I create a DNS zone using the wizard, the settings are :

    Template : Default
    Server :
    Client : blank
    Domain :
    IP Address : (address of not
    NS 1 :
    NS 2 :
    Email : [email protected]
    This then creates the zone and adds the following records for that zone :

    A 	0 	3600 	
    A 	mail 	       	0 	3600 	
    A 	www 	       	0 	3600 	
    MX 	10 	3600 	
    NS 	0 	3600 	
    NS 	0 	3600

    I was wondering if the A record for mail is correct as its public IP address is not

    I then add a new website, all other settings are default:

    The problem is that when I try to access via a browser I get :

    I can access the homepage if I enter the public IP. However it shows the default Apache page not the ISPConfig page.

    Any help would be greatly appreciated!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    you have to add 2 additional a-records in the zone when the ns records are subdomains of the same zone. one for ns0 and one for ns1. you should also correct the ip address to point to the mail server.
  3. saco721

    saco721 Member HowtoForge Supporter

    Hey Till,

    I have tried adding the 2 A records for the nameservers, still no homepage.

    I was wondering if I should add server IP addresses under system as there are none there at the moment. Also server config shows the gateway as and the nameservers as, Should I change these?.

    Thanks very much for you help.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Check /var/log/syslog for named / bind errors.


Share This Page