Cannot access sites 404 error

Discussion in 'ISPConfig 3 Priority Support' started by Mister, Feb 27, 2014.

  1. Mister

    Mister Member

    Loving the control panel, only problem I cannot access the sites I create LOL

    Followed the perfect server set up on debian, all runs smoothly, but what do I have to configure so I can access the sites I create? I either get the default Nginx page or a 404 not found.

    Error log does not show much apart from:
    /usr/local/ispconfig/interface/lib/classes/simplepie.inc.php on line 9195
    PHP message: PHP Strict Standards: Non-static method SimplePie_Misc::entities_decode() should not be called statically in /usr/local/ispconfig/interface/lib/classes/simplepie.inc.php on line 9195

    I do not feel the above is related, probably a rookie mistake or I am missing a basic step in my set up of the sites...experts, please chime in
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    the simplepie error is not related to your issue.

    Do you get any errors in the error.log of the website, this log is in the "error" directory of the website.

    Did you access the website by its domain name? Thats nescessary for namebased hosts. If you do not have a dns record for that domain yet, try this: http://www.faqforge.com/linux/contr...ess-a-namebased-website-without-a-dns-record/

    Is your server vehind a router, in this case you will have to select the internal IP address for the website, not the external one.

    Are there any jobs listed in the jobqueue of the ispconfig monitor?
     
  3. Mister

    Mister Member

    Hi till, thanks, I thought the simple pie issue was nothing to worry about (at least for now)

    The log file of my website is empty

    I access my website by the domain name, I have entered DNS records in the control panel only, do I need to edit the vhosts in Nginx? Do I need to delete the default vhost in Nginx?

    Server is not behind a router, trying to get it right on Digital Ocean before I move to other servers. Cloudfare DNS, although I have paused protection for now.

    No jobs listed in job queue of Ispconfig monitor
     
  4. Mister

    Mister Member

    My virtual host file seems messed up: Nginx did not start after modifying this vhost file

    It looks like it writes to the vhost.err file instead of writing to the working copy
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    If you did not enter any custom nginx directives, the there might be something missing in your configuration. Rename the current vhost file to ...vhost.bak, then reanme the ...vhost.err file to .vhost and then restart nginx and post the error that you get on the screen and in the nginx log file.
     
  6. Mister

    Mister Member

    Hi till, thanks for the support

    Nginx error

    nginx: [emerg] could not build the server_names_hash, you should increase server_names_hash_bucket_size: 32
    nginx: configuration file /etc/nginx/nginx.conf test failed\[email protected]:~#

    I uncommented the line #server_names_hash_bucket_size 64 and now it works perfectly

    Thanks till for finding me the solution
     
    Last edited: Mar 1, 2014

Share This Page