Cannot access admin panel with browser

Discussion in 'Installation/Configuration' started by wiremeister, Jul 7, 2011.

  1. wiremeister

    wiremeister New Member

    ISP Config 2.2.39 is installed and apparently running on Mandriva 2008.1 (using Falko's Perfect Setup tutorial) on two x86 machines. I have installed ISPConfig twice. Once using HTTPS and once using HTTP.
    When trying to log in to admin using HTTP, both Firefox and IE will say similar things. That is Bad Request use HTTPS.
    When trying HTTPS, neither Firefox or IE will go to the site. Firefox gives this error:
    Secure Connection Failed

    An error occurred during a connection to XX.XX.XX.XX:81.

    Peer's certificate has an invalid signature.

    (Error code: sec_error_bad_signature)

    * The page you are trying to view can not be shown because the authenticity of the received data could not be verified.

    * Please contact the web site owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.
    IE simply says bad request. As though there is not a website there at all.

    I can connect to the servers using ports 80 and 443 with both browsers where httpd proudly states: It Works! (This makes me wonder if ISPConfig is running at all, but this was verified by Netstat -tap)

    Netstat -tap shows ISPconfig running and listening on port 81.

    I have tried 3 times to rebuild the root certificate using instructions found on another thread. No change in error.

    I am running IE8 and Firefox 5 though I also installed Firefox3 on another machine and came up with the same error.

    There were no problems connecting with MySQL during setup.

    I've been using ISPConfig for roughly six years now, and this is the first I have seen this error. Any help or ideas would be greatly appreciated. Two servers down for a week now, and must get running again! :confused:

    Thanks in advance.

    Netstat -tap output from two machines:
    tcp 0 0 *:81 *:* LISTEN 1232/ispconfig_http
    tcp 0 0 *:81 *:* LISTEN 7917/ispconfig_http
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. wiremeister

    wiremeister New Member

    Thanks for responding Till.

    I have followed the link and recreated the cert on both servers. This did not solve the problem. I get the same error with browsers.

    Even though netstat -tap is showing ispconfig up and running, when I go to the IP using http://xx.xx.xx.xx, I do not get the familiar screen saying that this is a shared IP as I should. I only get the default It Works! from apache. The same is true of https://xx.xx.xx.xx.

    This leads to me to believe that ISPConfig is not necessarily running. Or at least Apache2 is not. Possibility?

Share This Page