Can' t get SSL to work ...

Discussion in 'Installation/Configuration' started by avanmessen, Sep 20, 2009.

  1. avanmessen

    avanmessen New Member

    Hello !

    Here' s what I did :

    PHP:
    openssl genrsa -des3 -passout pass:yourpassword -out /root/ispconfig/httpd/conf/ssl.key/server.key2 1024
    openssl req 
    -new -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.csr/server.csr -days 365
    openssl req 
    -x509 -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -in /root/ispconfig/httpd/conf/ssl.csr/server.csr -out /root/ispconfig/httpd/conf/ssl.crt/server.crt -days 365
    openssl rsa 
    -passin pass:yourpassword -in /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.key/server.key
    chmod 400 
    /root/ispconfig/httpd/conf/ssl.key/server.key
    To recreate the server.crt file with correct settings.

    Bought a cerificate from rapidssl.com, sent them the
    contents of server.csr, replaced the contents of the
    server.crt file with the certificate I received in return
    from rapidssl.com and restarted ispconfig_server.

    Seems httpd won' t start anymore.

    Replaced server.crt with a backup I made before, all Ok.

    What am I missing ?

    :confused:

    Certificate is intended for the admin pages and webmail.
     
  2. till

    till Super Moderator

    Any errors in the error log or ssl log of the ispconfig webserver (these logfiles are in /root/ispconfig/httpd/.....).
     
  3. avanmessen

    avanmessen New Member

    Hi Till !

    The error_log says :

    The ssl_request_log says :

    Obviously my server isn' t "server1.example.com", thought
    that would be replaced when I recreated the server.csr ?!
    Guess that would be the problem ? Am I on the right track ?

    :eek:
     
  4. avanmessen

    avanmessen New Member

    Still no joy ! Anyone to help me out with this ?

    :(
     
  5. avanmessen

    avanmessen New Member

    Is there any commercial support available for ISPConfig ?
    I still can' t get it to work, have read through pages and
    pages of forum posts, tried a LOT of stuff to no avail ...

    I paste the official certificate in server.crt and restart the
    ispconfig_server and apache just dies on me !

    Forgot to mention I use a vmware appliance that I got
    pre-installed, that' s why there' s some errors in naming
    of the server e.g.

    It would be such a pain to reinstall from scratch, even
    more to migrate the sites and e-mail for the many users.

    :(
     

Share This Page