Can send mail/ can not receive

Discussion in 'Installation/Configuration' started by Kev King, Jan 26, 2010.

  1. Kev King

    Kev King New Member

    Have set up a couple of e-mail accounts to try out the mail, but I am not able to receive on any. Have tried Roundcube, Squirrelmail and Webmail. But they all give the same response.
    I can login to them all and send mail to my hotmail account, but when I reply or try to send a new one back, I get a reply almost immediately postmaster delivery failure.

    Using Ispconfig2.2.35 on Ubuntu 9.10

    All ports for mail are open, I think, and all green in server>services

    Used the http://www.howtoforge.com/perfect-server-ubuntu-9.10-karmic-koala-ispconfig-2 tutorial.

    Everything else is working as it should it would seem.

    Any ideas guys?
     
    Last edited: Jan 27, 2010
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?

    Also make sure that the MX records of your domains are pointing to the right server. You can check that with

    Code:
    dig mx yourdomain.com
     
  3. Kev King

    Kev King New Member

    There is nothing in the mail error log, and doesnt seem to be any errors in the maillog.

    I have attached the latest mail.log entries


    dig mx shows:

    ; <<>> DiG 9.6.1-P2 <<>> mx ks302345.kimsufi.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64838
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;ks302345.kimsufi.com. IN MX

    ;; AUTHORITY SECTION:
    kimsufi.com. 10800 IN SOA dns.ovh.net. tech.ovh.net. 2010012740 86400 3600 3600000 86400

    ;; Query time: 9 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Wed Jan 27 14:12:38 2010
    ;; MSG SIZE rcvd: 90
     

    Attached Files:

  4. falko

    falko Super Moderator ISPConfig Developer

    Are your email addresses of the form [email protected] or [email protected]? If the latter, you must check
    Code:
    dig mx kimsufi.com
     
  5. Kev King

    Kev King New Member

    Thanks for bearing with me falko, I think I dig'd the wrong address to begin with.
    I currently have 2 sites up and running, which I have dig mx.....

    postrangersgolfsociety.org.uk &
    berilacsshack.com

    I have also had a look in my manager control panel for my dedicated server. And have set e-mails to be handled by my own server and not the server provider, as per their instructions, for one of the sites. To see if that makes any difference. Have to wait 24hrs for this to go thru.

    Have included the results of dig mx my.sites.com for info anyway.

    I am sure this is really simple to resolve, and I am confusing myself more than anything.

    Your help is really appreciated

    Its just strange that I can e-mail out, but not receive, out of the 2 accounts that I have created?
     

    Attached Files:

  6. falko

    falko Super Moderator ISPConfig Developer

    There's no MX record for berilacsshack.com - you should create one.

    Is 91.121.136.184 the IP address of your server?
     
  7. Kev King

    Kev King New Member

    Yes falko

    I think I am now attacking this problem from 2 ways, and neither is working.

    Have asked my server company the same question, and have now hopefully set the right nameserver in the DNS zone with-in my OVH Manager.

    Have set mail to point to

    berilacsshack.com & postrangersgolfsociety.org.uk respectively and e-mails are in the format of [email protected] & [email protected]

    But I am gonna concentrate on the berilacsshack one for now and get that working first, as I use this as my testing server, in a way.
     
  8. Kev King

    Kev King New Member

    I think I have solved the issue. Well have tested this morning and can send/receive from berilacsshack.com, yipee.

    Not sure what the cure was tho, as it seems to take some time for alterations to become live.

    But as soon as I added a SPF record at my OVH manager it worked.
    Will follow the same steps at the other domain and see if it was a fluke or not, haha.

    Thanks for your assistance falko
     

Share This Page