Can Send but can't receive emails

Discussion in 'Installation/Configuration' started by lkirby541, Aug 9, 2007.

  1. lkirby541

    lkirby541 New Member

    I am using ispconfig and all is working except for the email i can send just fince but I can receive any email. I am running ubuntu 7.04 and have followed the perfect setup guide. I am using postfix. I have scoured the config files and for the life of me I can;t see what the issue could be. Below is what I get from the log file.

    Aug 9 00:36:28 server postfix/smtpd[10418]: connect from web52107.mail.re2.yahoo.com[206.190.48.110]
    Aug 9 00:36:28 server postfix/smtpd[10418]: 66B7711C3DB: client=web52107.mail.re2.yahoo.com[206.190.48.110]
    Aug 9 00:36:29 server postfix/cleanup[10422]: 66B7711C3DB: message-id=<612606.2663.qm@web52107.mail.re2.yahoo.com>
    Aug 9 00:36:29 server postfix/qmgr[9719]: 66B7711C3DB: from=<lauramariekirby@yahoo.com>, size=2037, nrcpt=1 (queue active)
    Aug 9 00:36:29 server postfix/local[10424]: 66B7711C3DB: to=<web1_lance@mail.thekirbyclan.com>, orig_to=<lance@thekirbyclan.com>, relay=local, delay=0.74, delays=0.71/0.01/0/0.02, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Aug 9 00:36:29 server postfix/qmgr[9719]: 66B7711C3DB: removed
    Aug 9 00:36:29 server postfix/smtpd[10418]: disconnect from web52107.mail.re2.yahoo.com[206.190.48.110]

    If any one could point me in the right direction so i can get this going that would be great.
     
  2. till

    till Super Moderator

    Please make sure that you enabled the maildir checkbox in ispconfig under management > server > settings on the mail tab.
     
  3. lkirby541

    lkirby541 New Member

    Can Send but can't receive

    I have thought of that to and I checked again just to double check that the maildir box is still checked. I did try one other thing I enabled forwarding on the mail mox that I am testing with and sent a message to it and I got the message at the mailbox that I forwarded to which was to a mailbox on an external domain. So i know that the message gets to the server getto the users mailbox at least and then turns around and forwards to another mail box. What I want to happen is for the users to be able to check from the webmail. Any other thoughts on this...
     
  4. till

    till Super Moderator

  5. lkirby541

    lkirby541 New Member

    I followed your link and did the suggestion as it said. I don't have any catchall accounts but I ran postfix reload anyways and sent my self a test email with the forwarding off on both my test account and now i can receive mail on one of the test accounts but not the other. Looks like we are almost there any other ideas.
     
  6. till

    till Super Moderator

    Is the domain that did not receive mail (without www !) listed in /etc/postfix/local-host-names
     
  7. lkirby541

    lkirby541 New Member

    Here is what my local-host-names file looks like i'm pretty new at this so i think it looks correct but maybe it isn't. I tried to change my server name from server.thekirbyclan.com to mail.thekirbyclan.com and everytime I changed it ispconfig would change it back so i added it below the line don't know if having it both ways will make a difference but i don't know how to get isp config to let me change it in the center.

    ###################################
    #
    # ISPConfig local-host-names Configuration File
    # Version 1.0
    #
    ###################################
    localhost
    server.thekirbyclan.com
    localhost.server.thekirbyclan.com
    localhost.thekirbyclan.com
    localhost.localdomain
    www.thekirbyclan.com
    www.r3mixdesigns.com
    gallery.r3mixdesigns.com
    thekirbyclan.com
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
    mail.thekirbyclan.com
    localhost.mail.thekirbyclan.com
     
  8. till

    till Super Moderator

    Which is the exact email address that does not work?
     
  9. lkirby541

    lkirby541 New Member

  10. till

    till Super Moderator

    Ok. The domain for this address is listed correctly. I just asked because emails for r3mixdesigns.com will not work until you add a co-domain r3mixdesigns.com with empty hostname to the website which shall receive the emails. Back to your original problem:

    1) Do you have any aliases for "admin" in /etc/aliases ?
    2) Please post the output of:

    grep 'admin@thekirbyclan.com' /etc/postfix/virtusertable
     
  11. edge

    edge HowtoForge Supporter

Share This Page