Can one change ?

Discussion in 'Installation/Configuration' started by misterm, Sep 20, 2005.

  1. misterm

    misterm Member HowtoForge Supporter

    Hello with all

    I return with my problems of permissions of users on the files, to see this topics.

    Then, I put myself the question, for you ask, if one can change the users & groups httpd, in the config of ispconfig, so that that is directly the users of the sites.

    User httpd >> web1_admin
    Group httpd >> web1

    If you known as that it is possible for me to make this solution there, to give me the order which is necessary to carry out to carry out this operation.

    Yours sincerely

    MM :confused: :confused:
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Enable SuExec in the ISPConfig management settings and run PHP as CGI-Script. Then PHP and all other CGI scripts are run as web admin user.
  3. misterm

    misterm Member HowtoForge Supporter

    How to make ?


    I agree of this solutions, but I would like to have myself how one recompille the waiter, because, for lack of technique, I do not know, how the recompiller, it is beautiful, of me remmĂȘttre, this solution, but to give me the most constructive possible solution.

    Thank you in advance

    MM :confused: :confused:
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You dont have to recompile anything. Just install the php-cgi packages of your linux distribution and remove the mod_php packages.

    Sorry, i dont have a step by step howto at hand for these steps.
  5. misterm

    misterm Member HowtoForge Supporter

    ok now I see


    But, my prob, it is that, I am under debian, is that I have to install php-cgi, by maintaining that the modules of php for apache, then, I would like to have myself how, when I to withdraw the modules of apache, which will be the config to carry out to activate php-cgi in apache, because I am perhaps a person who includes/understands the things badly, but I is not to find any reference on the Web, to activate php-cgi under google.

    My config is as follows:
    apache 2.0, php 4.4.0, ispconfig 2.0.7

    Another thing which doesn't have anything to have, but that would be effective, for steps badly of anybody, which have already to use ispconfig (old version), to make patchs of update there, instead of doing all to reinstall the ISP, I do not know that you can think about it, but that for certain I will be better believe?

    Thank you still for your patience in my connection.

    MM :confused: ;)

Share This Page