Can not run axfr from slave dns

Discussion in 'Installation/Configuration' started by lucani, Jan 31, 2010.

  1. lucani

    lucani New Member

    Hello!

    My problem is that I can't import dns zone by axfr to my slave Bind from MyDNS master.

    When I type in my slave:

    everything is ok, but when it'ss trying to sync (by axfr :

    )

    I get error

    I've also noticed that MyDNS can't bind to port #53 (I run:

    ) Is it the reason ?

    Everything worked, but i had to reinstall all master : /
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If mydns cant bind toport 53, then you must ahve another dns server installed on your system. Stop this other dns server and then start mydns.
     
  3. lucani

    lucani New Member

    Is in linux any command to check current binded ports by services?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    netstat -tap
     
  5. lucani

    lucani New Member

    mydns -v says:
    Code:
    mydns[12383]: ipv4_listener: bind on socket 6 (TCP) failed: 127.0.0.1+53: Address is already in use
    but in netstat -tap I cant see any port 53 ! : /

    I have also to say that I have a problem with internal DNS settings, it means that after installation without internet cable plugged in I couldnt browse the internet, I installed package resolvconf and it started working, yesterday I unistall it and everything is working fine (i didnt restart machine)

    ---------------------

    I also used this fix: http://howtoforge.com/forums/showpost.php?p=184308&postcount=15
     
    Last edited: Jan 31, 2010
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you have still the resolveconf running. Resolving wills top working as soon as you restart the server. So you should reinstall the resolver, configure it to listen only on ip 127.0.0.1 and then edit the mydns.conf file and configure it to listen on all ip addresses except 127.0.0.1
     
  7. lucani

    lucani New Member

    where i can configure it ?

    Is it the only reason of this problem? I checked that on old master was same problem but axfr worked :/

    Is it ok if i have my public ip as my nameserver (/etc/network/interfaces)? Maybe I should type 127.0.0.1 ?
     
    Last edited: Jan 31, 2010
  8. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ? What's in /etc/mydns.conf?
     
  9. lucani

    lucani New Member

    web:~# netstat -tap
    mydns.conf

    netstat -ltnp | grep :53

    says:

    so maybe everything is ok?
    Is it possible that I done mistake in axfr.c fix but MyDNS started ? Can I reinstall MyDNS without reinstalling ISPConfig3 (=reinstalling system) ?
     
    Last edited: Feb 1, 2010
  10. falko

    falko Super Moderator ISPConfig Developer

    As far as I can see, MyDNS is listening on all IP addresses. If you don't want it to listen on 127.0.0.1, you should explicitly list your other IP addresses in the
    Code:
    listen =
    line in /etc/mydns.conf and restart MyDNS.
     
  11. lucani

    lucani New Member

    I dont know... In last post I said that it seems to be ok, but I'm not sure

    On the other thread someone said me that I shouldnt had to do malually fix to MyDNS... but week ago in my old server all worked good... --.--
     

Share This Page