Can not recieve mail with de virtual mail adress

Discussion in 'Installation/Configuration' started by Mounir, Jul 21, 2006.

  1. Mounir

    Mounir New Member

    Can not recieve mail with mail adress created with ISPConfig

    Hi every 1,

    I set The Perfect Setup - Debian Sarge (3.1) + ISPConfig :)) Thanks Falko &..)

    Everythings goes well. but one probleme.
    I can not recieve mail with de mail adress i create with ISPConfig, but i can sent mail.

    I can only sent and recieve with the system user.

    I made 3 domains with mail adress.

    Thanks,
    Ihope some 1 can help.
    sorry my english is not well!!
     
    Last edited: Jul 21, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in the mail log when you send a mail to your server?
    What's the output of
    Code:
    netstat -tap
    ?
    Is the MX record for your domain correct? You can check with
    Code:
    dig mx yourdomain.com
     
  3. Mounir

    Mounir New Member

    1-Mail.log

    I sent mail to 1st mail adress i get this (1st hostdomain)

    Jul 22 15:30:24 mail authdaemond.plain: modules="authpam", daemons=5
    Jul 22 15:30:29 mail postfix/postfix-script: starting the Postfix mail system
    Jul 22 15:30:29 mail postfix/master[1332]: daemon started -- version 2.1.5
    Jul 22 15:30:42 mail postfix/postfix-script: stopping the Postfix mail system
    Jul 22 15:30:42 mail postfix/master[1332]: terminating on signal 15
    Jul 22 15:30:44 mail postfix/postfix-script: starting the Postfix mail system
    Jul 22 15:30:44 mail postfix/master[1559]: daemon started -- version 2.1.5
    Jul 22 15:31:21 mail postfix/smtpd[1624]: connect from smtp05.wanadoo.nl[194.134.35.145]
    Jul 22 15:31:21 mail postfix/smtpd[1624]: DA0A311395B: client=smtp05.wanadoo.nl[194.134.35.145]
    Jul 22 15:31:21 mail postfix/cleanup[1627]: DA0A311395B: message-id=<002201c6ad94$564c64d0$0a00000a@blabla>
    Jul 22 15:31:21 mail postfix/qmgr[1571]: DA0A311395B: from=<[email protected]>, size=4313, nrcpt=1 (queue active)
    Jul 22 15:31:21 mail postfix/smtpd[1624]: disconnect from smtp05.wanadoo.nl[194.134.35.145]
    Jul 22 15:31:22 mail postfix/cleanup[1627]: 06C5511395C: message-id=<002201c6ad94$564c64d0$0a00000a@blabla>
    Jul 22 15:31:22 mail postfix/qmgr[1571]: 06C5511395C: from=<[email protected]>, size=4455, nrcpt=1 (queue active)
    Jul 22 15:31:22 mail postfix/local[1628]: DA0A311395B: to=<[email protected]>, relay=local, delay=1, status=sent (for
    warded as 06C5511395C)
    Jul 22 15:31:22 mail postfix/qmgr[1571]: DA0A311395B: removed
    Jul 22 15:31:22 mail postfix/smtp[1629]: 06C5511395C: to=<[email protected]>, orig_to=<[email protected]>, rel
    ay=none, delay=0, status=bounced (mail for mail.hostdomain.com loops back to myself)
    Jul 22 15:31:22 mail postfix/cleanup[1627]: 2947211395B: message-id=<[email protected]>
    Jul 22 15:31:22 mail postfix/qmgr[1571]: 2947211395B: from=<>, size=6302, nrcpt=1 (queue active)
    Jul 22 15:31:22 mail postfix/qmgr[1571]: 06C5511395C: removed
    Jul 22 15:31:23 mail postfix/smtp[1631]: 2947211395B: to=<[email protected]>, relay=gmail-smtp-in.l.google.com[64.233.183.
    27], delay=1, status=sent (250 2.0.0 OK 1153575083 l21si3225689nfc)
    Jul 22 15:31:23 mail postfix/qmgr[1571]: 2947211395B: removed
    Jul 22 15:31:23 mail imaplogin: Connection, ip=[::ffff:127.0.0.1]
    Jul 22 15:31:24 mail imaplogin: LOGIN, user=postmaster, ip=[::ffff:127.0.0.1], protocol=IMAP
    Jul 22 15:31:24 mail imaplogin: LOGOUT, user=postmaster, ip=[::ffff:127.0.0.1], headers=0, body=0, time=0

    I sent mail to Second mail adress i get this (1st hostdomain)

    Jul 22 15:32:23 mail imaplogin: Connection, ip=[::ffff:127.0.0.1]
    Jul 22 15:32:23 mail imaplogin: LOGIN, user=postmaster, ip=[::ffff:127.0.0.1], protocol=IMAP
    Jul 22 15:32:23 mail imaplogin: LOGOUT, user=postmaster, ip=[::ffff:127.0.0.1], headers=0, body=0, time=0
    Jul 22 15:33:23 mail imaplogin: Connection, ip=[::ffff:127.0.0.1]
    Jul 22 15:33:23 mail imaplogin: LOGIN, user=postmaster, ip=[::ffff:127.0.0.1], protocol=IMAP
    Jul 22 15:33:23 mail imaplogin: LOGOUT, user=postmaster, ip=[::ffff:127.0.0.1], headers=0, body=0, time=0
    Jul 22 15:34:23 mail imaplogin: Connection, ip=[::ffff:127.0.0.1]
    Jul 22 15:34:23 mail imaplogin: LOGIN, user=postmaster, ip=[::ffff:127.0.0.1], protocol=IMAP
    Jul 22 15:34:23 mail imaplogin: LOGOUT, user=postmaster, ip=[::ffff:127.0.0.1], headers=0, body=0, time=0
    Jul 22 15:35:23 mail imaplogin: Connection, ip=[::ffff:127.0.0.1]
    Jul 22 15:35:23 mail imaplogin: LOGIN, user=postmaster, ip=[::ffff:127.0.0.1], protocol=IMAP
    Jul 22 15:35:23 mail imaplogin: LOGOUT, user=postmaster, ip=[::ffff:127.0.0.1], headers=0, body=0, time=0
    Jul 22 15:36:19 mail postfix/smtpd[1714]: connect from smtp05.wanadoo.nl[194.134.35.145]
    Jul 22 15:36:19 mail postfix/smtpd[1714]: 9F3B611395B: client=smtp05.wanadoo.nl[194.134.35.145]
    Jul 22 15:36:19 mail postfix/cleanup[1717]: 9F3B611395B: message-id=<002d01c6ad95$07eb95d0$0a00000a@blabla>
    Jul 22 15:36:19 mail postfix/qmgr[1571]: 9F3B611395B: from=<[email protected]>, size=1100, nrcpt=1 (queue active)
    Jul 22 15:36:19 mail postfix/smtpd[1714]: disconnect from smtp05.wanadoo.nl[194.134.35.145]
    Jul 22 15:36:20 mail postfix/pickup[1570]: 0079611395C: uid=10017 from=<admin2>
    Jul 22 15:36:20 mail postfix/cleanup[1717]: 0079611395C: message-id=<[email protected]>
    Jul 22 15:36:20 mail postfix/qmgr[1571]: 0079611395C: from=<[email protected]>, size=368, nrcpt=1 (queue active)
    Jul 22 15:36:20 mail postfix/local[1731]: 0079611395C: to=<admispconfig@localhost>, relay=local, delay=1, status=sent (delive
    red to command: /usr/bin/procmail -f-)
    Jul 22 15:36:20 mail postfix/qmgr[1571]: 0079611395C: removed
    (END)


    I sent mail to de virtual mailadress domain2 and domain3 i get nothing atall.



    2-netstat -tap

    mail:/var/log# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:imaps *:* LISTEN 1110/couriertcpd
    tcp 0 0 *:pop3s *:* LISTEN 1133/couriertcpd
    tcp 0 0 localhost.localdo:mysql *:* LISTEN 1196/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 1119/couriertcpd
    tcp 0 0 *:imap2 *:* LISTEN 1096/couriertcpd
    tcp 0 0 *:www *:* LISTEN 1448/apache2
    tcp 0 0 *:81 *:* LISTEN 1412/ispconfig_http
    tcp 0 0 *:ftp *:* LISTEN 1594/proftpd: (acce
    tcp 0 0 virtual-ip1.xxxx:domain *:* LISTEN 1579/named
    tcp 0 0 mail.xxxxxxxx.:domain *:* LISTEN 1579/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 1579/named
    tcp 0 0 *:ssh *:* LISTEN 1352/sshd
    tcp 0 0 *:10008 *:* LISTEN 1609/perl
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 1579/named
    tcp 0 0 *:smtp *:* LISTEN 1559/master
    tcp 0 0 *:https *:* LISTEN 1448/apache2
    tcp 0 0 localhost.localdo:imap2 localhost.localdo:32794 TIME_WAIT -
    tcp 0 148 mail.xxxxxxxxx.com:ssh 10.0.0.10:1522 ESTABLISHED1401/0
    mail:/var/log#


    3- MX Record

    ; <<>> DiG 9.2.4 <<>> mx domain.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31484
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;domain.com. IN MX

    ;; ANSWER SECTION:
    domain.com. 10899 IN MX 20 mx1.xxx.net.
    domain.com. 10899 IN MX 30 mx2.xxxx.net.
    domain.com. 10899 IN MX 10 mail.domain.com.

    4-main.cf

    # See /usr/share/postfix/main.cf.dist for a commented, more complete version

    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    myhostname = mail.domain.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = mail.domain.com, localhost.domain.com, localhost
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/
    mailbox_command =

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names


    Thanks Falko,:D
     
    Last edited: Jul 22, 2006
  4. Mounir

    Mounir New Member

    Has somebody an idea??

    Thanx:)
     
  5. falko

    falko Super Moderator ISPConfig Developer

    This doesn't help me at all. Can you post your three domains here (the real names)?
     
  6. Mounir

    Mounir New Member

    my onley domain that works is the domain that i register. domain.com

    The othet 2 domains i don't register jet. may be is that the probleme why they don't work???


    mail:~# dig mx domain.com

    ; <<>> DiG 9.2.4 <<>> mx domain.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43507
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;digitallou.com. IN MX

    ;; ANSWER SECTION:
    domain.com. 14400 IN MX 20 mx1.cyso.net.
    domain.com. 14400 IN MX 30 mx2.cyso.net.
    domain.com. 14400 IN MX 10 mail.domain.com.
     
    Last edited: Jul 24, 2006
  7. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Is the glue record set correct for your MX Record, especially for
    mail.digitallou.com (dig mail.digitallou.com)
     
  8. Mounir

    Mounir New Member

    i get this with dig mail.domain.com
    ===========================

    mail:~# dig mail.domain.com

    ; <<>> DiG 9.2.4 <<>> mail.domain.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39215
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mail.digitallou.com. IN A

    ;; ANSWER SECTION:
    mail.domain.com. 10001 IN A ip nr


    ========================================================
    Do i have to register by an registeraar olso de virtual domain in orther to use the mail adres???

    Thanx
     
    Last edited: Jul 24, 2006
  9. falko

    falko Super Moderator ISPConfig Developer

    Yes, you must register all your domains...
     
  10. Mounir

    Mounir New Member

    Ok thanx,
    now i guess it must be working. When i register the other doamins.

    Great.

    Thanx guys.:D :cool: :D
     

Share This Page