can not login via domain anymore

Discussion in 'General' started by Michael Weber, Nov 16, 2018.

  1. Michael Weber

    Michael Weber New Member

    Good Morning,
    i have a quite odd problem on one of my servers managed with ispconfig 3. after the update of ispconfig i can only log in as admin with the ip adress but not longer with the domain name (

    So i checked really every single option and compared it with one of the other machines. same os, same version ... well basically same everything and they had no problems after the update. deleted all the caches in 3 or 4 browsers. really nothing helped. so i checked the apache logfiles and there i found the problem: myip - - [16/Nov/2018:10:45:41 +0100] "GET /datalogstatus.php HTTP/1.1" 200 737 ... myip - - [16/Nov/2018:10:45:41 +0100] "POST /login/index.php HTTP/1.1" 302 853 ... myip - - [16/Nov/2018:10:45:41 +0100] "GET /index.php HTTP/1.1" 302 605 ... myip - - [16/Nov/2018:10:45:41 +0100] "GET /login/ HTTP/1.1" 200 4021 ... myip - - [16/Nov/2018:10:45:42 +0100] "GET /js/scrigo.js.php HTTP/1.1" 200 2233 ...

    and suddenly 404 pops up ... myip - - [16/Nov/2018:10:45:42 +0100] "GET /login/dashboard/dashboard.php HTTP/1.1" 404 546 ... myip - - [16/Nov/2018:10:45:42 +0100] "GET /login/nav.php?nav=side HTTP/1.1" 404 530 ...

    that goes on for dashboard.php and all other stuff that follows.

    So obviously ipsconfig is looking in the wrong place. I double checked every path in the Config and can not figure out WHY he he is looking for that stuff in the /login/ subdirectory instead of the 'basedir' of ispconfig. There is no .htacess with rewrite stuff or anything like that.

    Problem is: It is really just that one Server. The other 2 are fine and behaving as expected.

    i am grateful for any ideas :)
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's ok and not an error.

    To fix your issue, empty browser cache and delete cookies in the Browser.
  3. Michael Weber

    Michael Weber New Member

    I tried that at the very beginning in all (Firefox, Chrome, Edge and some Android thing i never used before) anyway. Firefox Cache is disabled at the first place. Sorry i did not mention that.

    Problem is that i can not see any error or hickup at all in the server logfiles. i even enabled the display of PHP warnings and errors ... nothing to see that would point me in any direction.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    From which ispconfig version did you update to which version? For ispconfig, it does not matter which IP or domain is used as long as it points to the right server and when you can log in with the IP, then there can't be an issue in ispconfig itself or a crashed database record in my opinion. Problems with failed logins are known for updates from 3.0.x to 3.1 when there was an active session open, then this session crashes and the cookie and browser cache need to be cleared to fix it.
  5. Michael Weber

    Michael Weber New Member

    Updated from 3.1.11 to 3.1.13 with the '' script as always - no troubles while doing that and apart from that domain name trouble everything is running as smooth as it gets. The odd thing is that when i use false login credentials the login page responds with the expected error message while it seems just to reload when using right ones.

    I will try to figure that out cause it is annoying but it is not a serious issue cause noone else is using the Logon at the moment anyway.

    Thanks for your time anyway :)
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to run a repair on all tables in dbispconfig database with phpmyadmin, maybe the session table is crashed somehow.
  7. Michael Weber

    Michael Weber New Member

    That indeed solved the Problem. After a 'repair' i called the site a last time with the IP, clicked on the 'lock' symbol and deleted the cookies by hand. Then i typed in the domain and was finally able to login properly.

    Thanks for your time and ideas again!

Share This Page