can not login to squirrelmail or ispconfig

Discussion in 'Installation/Configuration' started by Al1937, Sep 16, 2012.

  1. Al1937

    Al1937 New Member

    I finally got my DNS zone set up where I can get my server on the net.
    BUT
    I can't login to squirrelmail or ispconfig. I use my server log on ID and my server logon password or my sql password. Nothing works.
    What should I be using? Please help.
     
  2. rosehosting

    rosehosting Member

    Are you receiving an error message when you try login? Did you check the log files?
     
  3. Al1937

    Al1937 New Member

    No error message- just "invalid login"
    Where are the log files?
    I'll be gone rest of day, till tonight
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your mail log (in the /var/log/ directory)?
     
  5. Al1937

    Al1937 New Member

    Results of most recent mail.log

    Sep 20 02:44:46 server1 dovecot: auth-worker: mysql(localhost): Connected to database dbispconfig
    Sep 20 02:44:48 server1 dovecot: imap-login: Aborted login (auth failed, 1 attempts): user=<al1937@akbpro.com>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
    Sep 20 02:45:02 server1 dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Sep 20 02:45:02 server1 dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Sep 20 02:45:02 server1 postfix/smtpd[27289]: connect from localhost.localdomain[127.0.0.1]
    Sep 20 02:45:02 server1 postfix/smtpd[27289]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Sep 20 02:45:02 server1 postfix/smtpd[27289]: disconnect from localhost.localdomain[127.0.0.1]
    root@server1:/var/log#
    ---------------------------------------
    After connecting and trying to log in. https://server1.akbpro.com:8080
    /var/log/ispconfig# cat ispconfig.log
    After connecting and trying to log in.
    Had nothing in it 0bytes
     
  6. Al1937

    Al1937 New Member

    My "dig" results.
    Are they correct or do I still have a DNS problem?

    ; <<>> DiG 9.8.1-P1 <<>> server1.akbpro.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36058
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;server1.akbpro.com. IN A

    ;; ANSWER SECTION:
    server1.akbpro.com. 14400 IN CNAME akbpro.com.
    akbpro.com. 14400 IN A 192.168.0.100

    ;; Query time: 166 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Thu Sep 20 07:34:07 2012
    ;; MSG SIZE rcvd: 66

    root@server1:/var/log/ispconfig#

    ; <<>> DiG 9.8.1-P1 <<>> akbpro.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39978
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;akbpro.com. IN A

    ;; ANSWER SECTION:
    akbpro.com. 14400 IN A 192.168.0.100

    ;; Query time: 85 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Thu Sep 20 07:43:38 2012
    ;; MSG SIZE rcvd: 44

    root@server1:/var/log/ispconfig#

    ; <<>> DiG 9.8.1-P1 <<>> server1
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 6194
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;server1. IN A

    ;; AUTHORITY SECTION:
    . 1328 IN SOA a.root-servers.net. nstld.verisign-grs.com. 2012091901 1800 900 604800 86400

    ;; Query time: 43 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Thu Sep 20 07:45:13 2012
    ;; MSG SIZE rcvd: 100

    root@server1:/var/log/ispconfig#
     
  7. falko

    falko Super Moderator ISPConfig Developer

    You're using a private IP address in your DNS records which means you can connect only from within your local network.
     
  8. Al1937

    Al1937 New Member

    Can you give me an example of how my DNS zones should be assigned for akbpro.com and server1?
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Just use your public IP address and create an A record for server1.
     
  10. Al1937

    Al1937 New Member

    I used this command to get my public IP address.
    wget -q -O - checkip.dyndns.org|sed -e 's/.*Current IP Address: //' -e 's/<.*$//'
    It returned 68.59.148.130
    I set an A record to server1 to 68.59.148.130 where akbpro.com is hosted.
    I gave up on Ubuntu 12.04 and re-installed Ubuntu 11.04
    When ever I was asked to enter: Country,State,Organization,Department,Name, email address I entered my real data.
    I made no changes to resolv.conf or to any bind files
    ------------------------------------------------------------------
    root@server1:~# dig server1.akbpro.com

    ; <<>> DiG 9.7.3 <<>> server1.akbpro.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2533
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 1280
    ;; QUESTION SECTION:
    ;server1.akbpro.com. IN A

    ;; ANSWER SECTION:
    server1.akbpro.com. 14400 IN A 68.59.148.130

    ;; Query time: 52 msec
    ;; SERVER: 192.168.0.1#53(192.168.0.1)
    ;; WHEN: Mon Sep 24 03:10:11 2012
    ;; MSG SIZE rcvd: 63

    root@server1:~#
    --------------------------------------------------------------------

    root@server1:~# dig server1

    ; <<>> DiG 9.7.3 <<>> server1
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61487
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 1280
    ;; QUESTION SECTION:
    ;server1. IN A

    ;; ANSWER SECTION:
    server1. 0 IN A 208.69.32.145

    ;; Query time: 22 msec
    ;; SERVER: 192.168.0.1#53(192.168.0.1)
    ;; WHEN: Mon Sep 24 03:15:26 2012
    ;; MSG SIZE rcvd: 52

    root@server1:~#
    --------------------------------------------------------------------
    root@server1:~# dig akbpro.com

    ; <<>> DiG 9.7.3 <<>> akbpro.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40488
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 1280
    ;; QUESTION SECTION:
    ;akbpro.com. IN A

    ;; ANSWER SECTION:
    akbpro.com. 0 IN A 208.69.32.145

    ;; Query time: 21 msec
    ;; SERVER: 192.168.0.1#53(192.168.0.1)
    ;; WHEN: Mon Sep 24 03:16:31 2012
    ;; MSG SIZE rcvd: 55

    root@server1:~#
    -------------------------------------------------------------------
    Where do I go from here?
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Now configure your router to forward all needed ports (e.g. 80 for http, 8080 for ISPConfig) to your ISPConfig server.
     
  12. Al1937

    Al1937 New Member

    Thank you,
    The port forwarding solved my problem.
     

Share This Page