Can not login to ftp after update

Discussion in 'Installation/Configuration' started by pecka33, Apr 2, 2020.

  1. pecka33

    pecka33 Member

    Hello, i did upgrade debian from 8 to 9 and my isp panel to latest version. But i can not login to ftp.

    I can use my root access, but if i create ftp account via panel, does not work. What should i check? In all case i can use only root account, but if my ftp accounts via isp panel does not work maybe should be error somewhere else. DB ant other things from panel working fine

    In apache rror log i can see, not sure if this could be problem.

    Thank you.

    mod_fcgid: stderr: PHP Warning: Declaration of db::query($sQuery = '') should be compatible with mysqli::query($query, $resultmode = NULL) in /usr/local/ispconfig/interface/lib/classes/ on line 0,
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Upgrading Debian 8 to 9 in ISPConfig system means:
    • Debian upgrade following instructions from
    • checking with ISPConfig Perfect Server quide for Debian 9 that all packages are installed and configured according to that quide
    • forcing ISPConfig reconfigure services with
      cd /tmp
      tar xvfz ISPConfig-3.1.15p3.tar.gz
      cd ispconfig3_install/install
      php -q update.php
      to ensure everything is now set up as ISPConfig needs on Debian 9.
    If something still does not work, read the log files when error happens.
    May be useful to check all services are running with
    systemctl --state=failed
    and do an overall check following this:
    PS You posted on Linux forum. There are ISPConfig 3 forums.
  3. Steini86

    Steini86 Active Member

    This has changed your systems PHP version. Did you adjust these settings in your server settings?
  4. pecka33

    pecka33 Member

    Thank you. I am using php 7.2. When i get home from work i will try command
    systemctl --state=failed.

    i did upgrade exactly like you wrote. Had some little problems with phpmyadmin - blank page etc, but it was solved by reupload files for phomyadmin. No other errors.
    I did update my ISP panel too. But not how you wrote but via command

    everythings looks fine, sites, databases, emails etc are created and working fine. Only FTP accounts not.

    i am not sure but in my case could be problem that in terminal during update panel i dont confirm reconfigure panel, choose N and not Y. But i am note sure with that 100 % because in last days i did a lot of updates. I guess here is none senee to start update again with command you send up.

    Steinii thank you. Can you please specifiy what exactly do you mean? I didnt change my php Settings for this domain.
  5. pecka33

    pecka33 Member

    Thank you again I run command systemctl --state=failed and get just

    0 loaded units listed. Pass --all to see loaded but inactive units, too.
    To show all installed unit files use 'systemctl list-unit-files'.

    When i use systemctl list-unit-files i can see following and acpid.service as disabled. I think that all looks and working fine, so maybe there is just problem with reconfigure via update.

    proc-sys-fs-binfmt_misc.automount static
    -.mount generated
    boot.mount generated
    dev-hugepages.mount static
    dev-mqueue.mount static
    media-cdrom0.mount generated
    proc-sys-fs-binfmt_misc.mount static
    sys-fs-fuse-connections.mount static
    sys-kernel-config.mount static
    sys-kernel-debug.mount static
    var-www-clients-client0-web1-log.mount generated
    var-www-clients-client0-web2-log.mount generated
    var-www-clients-client0-web3-log.mount generated
    acpid.path enabled
    systemd-ask-password-console.path static
    systemd-ask-password-wall.path static
    session-1135.scope transient
    acpid.service disabled
    amavis-mc.service generated
    amavis-snmp-subagent.service generated
    amavis.service generated
    amavisd-new.service generated
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    In that case, the update was useless as the reconfigure services is what is needed to adjust the config files. Rerun the update:

    cd /tmp
    tar xvfz ISPConfig-3.1.15p3.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    and choose to reconfigure services this time.
  7. pecka33

    pecka33 Member

    Thank sou. I did reinstall and during update a choose everywhere yes - reconfigure. Then i did reboot of my vps, remove ftp accounts created in panel and create new. But still can not login to ftp account.

    In all case, ftp accounts is not necessary for me, i can use root account to upload are web files etc., but i would like to know reason why this does not work. I am worry that somewhere could be any fatal error, but all services working fine for me, just ftp not.

    I am sorry for my reply, but i am new in VPS and linux and learning :)
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Which FTP program do you use? And be sure that you are really using FTP and not SSH. FTP is the mode FTP or FTPS in your FTP program while SFTP is not FTP (even if the name is similar), SFTP is SSH and requires an SSH account on the server. So take care to use the mode FTP or FTPS in the FTP client. Also latest FileZilla versions may have issues with older pure-ftpd versions as shipped with Debian 9, so trying different FTP client is also worth a try.
  9. pecka33

    pecka33 Member

    Thank you so much. Yes, for my root account I am using WinSCP with SFTP. For my FTP account created via panel i try to use winscp too with FTP protocol, and tried filezilla too with FTP.

    But now i tried login via and this is working fine. In case i tried other ftp client, for example, or winscp/filezilla, i can not login.

    So i know that FTP works, but i am not sure why only from one source here Maybe somewhere in vps config could be blocked some ports, i am not sure about it, because I am beginner, not expert :)

    I am not sure if there is not something like DNS for ftp config and panel. Mybe i have to just wait.

Share This Page