Can not install SSL with wildchar.

Discussion in 'General' started by ozgurerdogan, Apr 20, 2020.

  1. ozgurerdogan

    ozgurerdogan Member

    I simple choose *.domain.com when installing Lets En. SSL but, it gets installed only domain.com.
    Am I missing something?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If you run ISPConfig 3, using cerbot from the command line has a tendency to mess up LE in ISPConfig. So do not use LE in ISPConfig and use certbot on the command line.
    That said, wildcard certs are supported on certbot version 0.22.0 and later. So check your certbot version first.
    Using Internet Search Engines I found this:
    https://community.letsencrypt.org/t/wildcard-domain-step-by-step/58250
     
  3. ozgurerdogan

    ozgurerdogan Member

    I am not using certboot in bash. Only UI of Ispconfig.

    In dns records of DNS CAA Record,
    I see, Use Wildcard SSL checkbox is unticked. Is this something related?
     
  4. ozgurerdogan

    ozgurerdogan Member

    Yes after checking it I think all ok now.
     
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  6. ozgurerdogan

    ozgurerdogan Member

    One question, I am holding dns records on cloudflare, so do I still have to create that DNS CAA Record there?
     
  7. ahrasis

    ahrasis Well-Known Member

    I am using CF and the answer is yes.
     
  8. ozgurerdogan

    ozgurerdogan Member

    I did not have this record on other panels like DA or SolidCP. Will look into it.
     
  9. ahrasis

    ahrasis Well-Known Member

  10. ozgurerdogan

    ozgurerdogan Member

Share This Page