Can not install any PHP version

Discussion in 'Installation/Configuration' started by pecka33, Dec 1, 2021.

  1. pecka33

    pecka33 Member

  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    By "latest debian" you mean Debian 11? Please verify.
    You really should show what command. Show in code tags including the error output.
    Verify that host can connect to internet. Verify the apt system works, with for example
    Code:
    apt update
    Then show what package from which repository you are trying to install.
     
  3. pecka33

    pecka33 Member

    Thank you. Yes, i am using Debian GNU/Linux 11 (bullseye). My host can access to internet, i am using apache, mysql atc. and sites and when i tried to type
    Code:
    apt-get install php5.6 php5.6-cli php5.6-cgi php5.6-fpm php5.6-gd php5.6-mysql php5.6-imap php5.6-curl php5.6-intl php5.6-pspell php5.6-recode php5.6-sqlite3 php5.6-tidy php5.6-xmlrpc php5.6-xsl php5.6-zip php5.6-mbstring php5.6-soap php5.6-opcache libicu65 php5.6-common php5.6-json php5.6-readline php5.6-xml
    
    get error that could not be found

    Code:
    E: Nelze najít balík php5.6-cli
    E: Nelze najít balík vyhovující masce „php5.6-cli“
    E: Nelze najít balík vyhovující regulárnímu výrazu „php5.6-cli“
    E: Nelze najít balík php5.6-cgi
    E: Nelze najít balík vyhovující masce „php5.6-cgi“
    E: Nelze najít balík vyhovující regulárnímu výrazu „php5.6-cgi“
    E: Nelze najít balík php5.6-fpm
    E: Nelze najít balík vyhovující masce „php5.6-fpm“
    E: Nelze najít balík vyhovující regulárnímu výrazu „php5.6-fpm“
    E: Nelze najít balík php5.6-gd
    E: Nelze najít balík vyhovující masce „php5.6-gd“
    .....
    In my source list are lines

    Code:
    #
    
    # deb cdrom:[Debian GNU/Linux 8.0.0 _Jessie_ - Official amd64 NETINST Binary-1 20150425-12:50]/ buster main contrib non-free
    
    #deb cdrom:[Debian GNU/Linux 8.0.0 _Jessie_ - Official amd64 NETINST Binary-1 20150425-12:50]/ buster main contrib non-free
    
    #deb http://ftp.cz.debian.org/debian/ buster main contrib non-free
    #deb-src http://ftp.cz.debian.org/debian/ buster main contrib non-free
    
    #deb http://security.debian.org/ buster/updates main contrib non-free
    #deb-src http://security.debian.org/ buster/updates main contrib non-free
    
    # stretch-updates, previously known as 'volatile'
    #deb http://ftp.cz.debian.org/debian/ buster-updates main contrib non-free
    #deb-src http://ftp.cz.debian.org/debian/ buster-updates main contrib non-free
    
    # stretch-backports, previously on backports.debian.org
    #deb http://http.debian.net/debian/ buster-backports main contrib non-free
    #deb-src http://http.debian.net/debian/ buster-backports main contrib non-free
    
    deb http://deb.debian.org/debian bullseye main contrib non-free
    deb-src http://deb.debian.org/debian bullseye main contrib non-free
    
    deb http://deb.debian.org/debian-security/ bullseye-security main contrib non-free
    deb-src http://deb.debian.org/debian-security/ bullseye-security main contrib non-free
    
    deb http://deb.debian.org/debian bullseye-updates main contrib non-free
    deb-src http://deb.debian.org/debian bullseye-updates main contrib non-free
    
    deb http://httpredir.debian.org/debian stable main contrib
    
    
    
    
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What shows command
    Code:
    LANG=C apt-get install php5.6 php5.6-cli php5.6-cgi php5.6-fpm php5.6-gd php5.6-mysql php5.6-imap php5.6-curl php5.6-intl php5.6-pspell php5.6-recode php5.6-sqlite3 php5.6-tidy php5.6-xmlrpc php5.6-xsl php5.6-zip php5.6-mbstring php5.6-soap php5.6-opcache libicu65 php5.6-common php5.6-json php5.6-readline php5.6-xml
    What shows
    Code:
    LANG=C apt policy php5.6
    What shows
    Code:
    LANG=C ls -lh /etc/apt/sources.list.d/
     
  5. pecka33

    pecka33 Member

    Thank you. When i used first command you wrote i get:

    Code:
    [email protected]:~# LANG=C apt-get install php5.6 php5.6-cli php5.6-cgi php5.6-fpm php                                                                                                             5.6-gd php5.6-mysql php5.6-imap php5.6-curl php5.6-intl php5.6-pspell php5.6-rec                                                                                                             ode php5.6-sqlite3 php5.6-tidy php5.6-xmlrpc php5.6-xsl php5.6-zip php5.6-mbstri                                                                                                             ng php5.6-soap php5.6-opcache libicu65 php5.6-common php5.6-json php5.6-readline                                                                                                              php5.6-xml
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    Note, selecting 'php5.6-json' for regex 'php5.6'
    Note, selecting 'php5.6-common' for regex 'php5.6'
    Package php5.6-common is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    Package php5.6-json is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    E: Unable to locate package php5.6-cli
    E: Couldn't find any package by glob 'php5.6-cli'
    E: Couldn't find any package by regex 'php5.6-cli'
    E: Unable to locate package php5.6-cgi
    E: Couldn't find any package by glob 'php5.6-cgi'
    E: Couldn't find any package by regex 'php5.6-cgi'
    E: Unable to locate package php5.6-fpm
    E: Couldn't find any package by glob 'php5.6-fpm'
    E: Couldn't find any package by regex 'php5.6-fpm'
    E: Unable to locate package php5.6-gd
    E: Couldn't find any package by glob 'php5.6-gd'
    E: Couldn't find any package by regex 'php5.6-gd'
    E: Unable to locate package php5.6-mysql
    E: Couldn't find any package by glob 'php5.6-mysql'
    E: Couldn't find any package by regex 'php5.6-mysql'
    E: Unable to locate package php5.6-imap
    E: Couldn't find any package by glob 'php5.6-imap'
    E: Couldn't find any package by regex 'php5.6-imap'
    E: Unable to locate package php5.6-curl
    E: Couldn't find any package by glob 'php5.6-curl'
    E: Couldn't find any package by regex 'php5.6-curl'
    E: Unable to locate package php5.6-intl
    E: Couldn't find any package by glob 'php5.6-intl'
    E: Couldn't find any package by regex 'php5.6-intl'
    E: Unable to locate package php5.6-pspell
    E: Couldn't find any package by glob 'php5.6-pspell'
    E: Couldn't find any package by regex 'php5.6-pspell'
    E: Unable to locate package php5.6-recode
    E: Couldn't find any package by glob 'php5.6-recode'
    E: Couldn't find any package by regex 'php5.6-recode'
    E: Unable to locate package php5.6-sqlite3
    E: Couldn't find any package by glob 'php5.6-sqlite3'
    E: Couldn't find any package by regex 'php5.6-sqlite3'
    E: Unable to locate package php5.6-tidy
    E: Couldn't find any package by glob 'php5.6-tidy'
    E: Couldn't find any package by regex 'php5.6-tidy'
    E: Unable to locate package php5.6-xmlrpc
    E: Couldn't find any package by glob 'php5.6-xmlrpc'
    E: Couldn't find any package by regex 'php5.6-xmlrpc'
    E: Unable to locate package php5.6-xsl
    E: Couldn't find any package by glob 'php5.6-xsl'
    E: Couldn't find any package by regex 'php5.6-xsl'
    E: Unable to locate package php5.6-zip
    E: Couldn't find any package by glob 'php5.6-zip'
    E: Couldn't find any package by regex 'php5.6-zip'
    E: Unable to locate package php5.6-mbstring
    E: Couldn't find any package by glob 'php5.6-mbstring'
    E: Couldn't find any package by regex 'php5.6-mbstring'
    E: Unable to locate package php5.6-soap
    E: Couldn't find any package by glob 'php5.6-soap'
    E: Couldn't find any package by regex 'php5.6-soap'
    E: Unable to locate package php5.6-opcache
    E: Couldn't find any package by glob 'php5.6-opcache'
    E: Couldn't find any package by regex 'php5.6-opcache'
    E: Unable to locate package libicu65
    E: Package 'php5.6-common' has no installation candidate
    E: Package 'php5.6-json' has no installation candidate
    E: Unable to locate package php5.6-readline
    E: Couldn't find any package by glob 'php5.6-readline'
    E: Couldn't find any package by regex 'php5.6-readline'
    E: Unable to locate package php5.6-xml
    E: Couldn't find any package by glob 'php5.6-xml'
    E: Couldn't find any package by regex 'php5.6-xml'
    
    next
    Code:
    [email protected]:~# LANG=C apt policy php5.6
    N: Unable to locate package php5.6
    N: Couldn't find any package by glob 'php5.6'
    
    and latest

    Code:
    [email protected]:~# LANG=C ls -lh /etc/apt/sources.list.d/
    total 0
    
    Mazybe i should change language of debian somewhere in files?
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Probably not. You can keep the OS in the language you prefer, just when pasting output of commands here add the LANG=C in front of the command so us foreigners can understand the text.
    What you should do is follow instructions in https://www.howtoforge.com/tutorial...fig-3-from-debian-packages-on-debian-8-and-9/, chapter 4, "Add the repository at packages.sury.org".
     
  7. pecka33

    pecka33 Member

    Thank you Taleman! Thats help me. I changed language to EN with UTF-8 too. But you reply help me a lot.

    Thank and have a nice day, you are amazing!
     

Share This Page