can not forward email to an account on the same domain

Discussion in 'Installation/Configuration' started by sygram, Jun 3, 2008.

  1. sygram

    sygram New Member

    Hi guys,

    i have the following issue.

    I have account1@domain.com and account2@domain.com . I go to account2 and set to forward all emails to account1. This is not working though. The emails are not forwarded. I have tried two lines at the account2 forward field :

    account1@domain.com
    web15_account1

    Does anyone know how to sort this out ? If i enter an "external domain" i.e. otheraccount@otherdomain.com (hosted on a different server) it is working fine

    I appreciate your answers

    Regards,

    Leon
     
  2. till

    till Super Moderator

    The forwarding should work even if the target is in the same domain. Which messages do you get in a mail log when such a message should be forwarded?
     
  3. sygram

    sygram New Member

    Thank you for your reply. This is a very fresh portion of the log. Although the email is delivered it is not forwarded to the other account of the same domain.

    Jun 6 07:51:59 cl-t039-440cl postfix/smtpd[28723]: connect from s7000.webappcabaret.net[209.11.152.3]
    Jun 6 07:52:00 cl-t039-440cl postfix/smtpd[28723]: setting up TLS connection from s7000.webappcabaret.net[209.11.152.3]
    Jun 6 07:52:00 cl-t039-440cl postfix/smtpd[28723]: TLS connection established from s7000.webappcabaret.net[209.11.152.3]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Jun 6 07:52:00 cl-t039-440cl postfix/smtpd[28723]: 99A1861693C: client=s7000.webappcabaret.net[209.11.152.3]
    Jun 6 07:52:00 cl-t039-440cl postfix/cleanup[28727]: 99A1861693C: message-id=<484924D3.1090503@extdomain.com>
    Jun 6 07:52:00 cl-t039-440cl postfix/qmgr[21126]: 99A1861693C: from=<user@extdomain.com>, size=1069, nrcpt=1 (queue active)
    Jun 6 07:52:00 cl-t039-440cl postfix/local[28729]: 99A1861693C: to=<root@server1.privatedns.com>, orig_to=<news@domain1.com>, relay=local, delay=0.31, delays=0.28/0.01/0/0.02, dsn=2.0.0, status=sent (delivered to maildir)
    Jun 6 07:52:00 cl-t039-440cl postfix/qmgr[21126]: 99A1861693C: removed
    Jun 6 07:52:00 cl-t039-440cl postfix/smtpd[28723]: disconnect from s7000.webappcabaret.net[209.11.152.3]


    Regards,

    Leon
     
  4. till

    till Super Moderator

    Is there a alias for "news" in the file /etc/aliases? If yes, remove this alias and then run:

    postmap /etc/aliases
     
  5. sygram

    sygram New Member

    Yes correct ! There are 4 entries :

    news: root
    newsadm: news
    newsadmin: news
    usenet: news


    Do i have to remove all or just the first ? How is this going to affect my system ?
    I mean why are these values here ?

    Thanks a lot
     
  6. till

    till Super Moderator

    These values are defaults of your linux distribution. It has no negative effect on your system if you remove all the 4 entries.
     
  7. sygram

    sygram New Member

    I just tried that. I commented out the lines, run /usr/sbin/postmap /etc/aliases and even restarted postfix. The result is the same...

    Any more thoughts ?

    Leon
     
  8. sygram

    sygram New Member

    Actually when i ran the command it gave me a few warnings, but no errors. I am not sure whether this makes a difference. It am trying to find out where do i set the forwards from one address to another, to check it manually.
     

Share This Page