Can Not access phpMyAdmin Unless using root credentials

Discussion in 'Installation/Configuration' started by MattB, Mar 7, 2014.

  1. MattB

    MattB New Member

  2. srijan

    srijan New Member HowtoForge Supporter

    Hi

    Please try the login for dbusers at http://yourIP/phpmyadmin

    Try to login with the database-username. Check that what error you are getting there? Try login with the ISPConfig-admin console & check that whether the user exists or not. Change your password for the database-user & try to do login with the new password.

    Br//
    Srijan
     
  3. MattB

    MattB New Member

    I have tried the IP address, tried changing the passwords, creating new users with no difference made.
    When I log in as root and view the user table in the mysql database the only users in the table are ispconfig and root
     
    Last edited: Mar 7, 2014
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you use the full mysql username incl. prefix, like it is displayed in the mysql user list in ispconfig? If you add a mysql user "joe" to a client, then the full username is something like c1joe.

    Please be aware that a mysql user is created when you add a database for him, so you can not use a mysql user without having a database.

    If you ware sure that you sued the correct username, then take a look at the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf, it must contain the correct mysql root password. if the password is wrong, ispconfig will not be able to create a mysql db and user.
     
  5. MattB

    MattB New Member

    I have tried changing the password in /usr/local/ispconfig/server/lib/mysql_clientdb.conf and mysql_secure_installation, rebooting the server. Adding a new user and still no luck

    When I log in as root and view the user table in the mysql database the only users in the table are still ispconfig and root.

    And yes the correct credentials are being used i.e c0blahblah
     
    Last edited: Mar 7, 2014
  6. MattB

    MattB New Member

    Ok, now after some delay this now seems to have done the trick.
     
    Last edited: Mar 8, 2014
  7. Nicram

    Nicram Member

    Did you try to make new user inside database with phpMyAdmin (after login as root) and check if it will work or not?
    How about MySQL and phpMyAdmin configuration?
     
  8. MattB

    MattB New Member

    I seem to have resolved the issue following the advice above. Even though it did not work instantly which I find bizarre. Thanks for the help guys.
     

Share This Page