Can not access new mail

Discussion in 'Installation/Configuration' started by heinerlamprecht, Apr 30, 2007.

  1. heinerlamprecht

    heinerlamprecht New Member

    Hi all,

    I've a new ISPConfig installation (on openSuSE 10.2) and created a domain and an email adress for this domain. I can send mails to that adress, but it is not possible to access the mail via POP3. According to the mail-log, the message has been received and delivered to the mailbox. I can also see the POP3-login, but I don't get the mail.

    Any hints, what might goes wrong or where to look at?


    Thanks,

    Heiner
     
  2. edge

    edge Active Member Moderator

    Did you maybe enable "Maildir" in ISPconfig?
    If so, dissable and try again. (ISPconfig > Managment > Settings > Email)
     
  3. mlz

    mlz New Member

    Do you have chroot enabled?
     
  4. heinerlamprecht

    heinerlamprecht New Member

    I did some more investigations. There also exist a "normal" shell user account, which I configured before creating the email adress. This user has the same local name ("heiner") as the email adress, and the mail is stored in his mailbox in /var/spool/mail. The user name of the email account is different, and this mailbox is still empty.

    After that, I changed the email adress ("test@...), but than the mail is rejected: "User unknown in local recipient table".

    @edge: I disabled Maildir-format, but it didn't changed anything. In general, I'd prefere Maildir, as it is more save. But are there any problems with ISPConfig when using this format?

    @mlz: I'm not aware of having enabled chroot. How/where can I check this? And for which processes should it be configured?


    Thanks,

    Heiner
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    No, it is the opposite :) You should use maildir with ISPConfig. But you must have a maildir capable pop3 / imap daemon installed. e.g. dovecot or courier.

    If you followed the perefct setup, you do not have a chroot capable SSH daemon, so chrooting must be disabled. This is the default, so you do not have to change anything.

    - Which pop3 / imap daemon do you have installed?
    - Did you follow the perfect setup guide?
    - Is the email address listed in the postfix virtusertable file?
     
  6. heinerlamprecht

    heinerlamprecht New Member

    Okay. I'm using courier.

    Yes, I followed the setup guide.

    At the moment, the situation is as follows:

    • I have configured two domains, each with one email adress.
    • When sending an email to the virtual email adress ("[email protected]"), the mail is rejected due to "User unknown in local recipient table".
    • When sending to the "real" email adress ("[email protected]"), the mail is accepted and stored locally, but only for the first configured domain. For the other domain, it is still rejected.
    • I can access the correct stored mail via POP3.

    So, there seems to be something screwed up with the virtual adresses. The virtusertable looks okay. At least, I can't see a difference between the two sets of lines:

    Code:
    ###################################
    #
    # ISPConfig virtusertable Configuration File
    #         Version 1.0
    #
    ###################################
    [email protected]    web1_test
    [email protected]    web1_test
    [email protected]    web1_test
    [email protected]    web1_test
    [email protected]    web2_hallo
    [email protected]    web2_hallo
    [email protected]    web2_hallo
    [email protected]    web2_hallo
    #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The virtusertable is fine. As you use courier, the maildir checkbox in ISPConfig must be enabled. I guess that the virtusertable file is not part of your postfix configuration.

    Do you have these two lines in your postfix main.cf:

    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names

    The path to the virtusertable file might differ a bit, thy must match the actual location on your server.
     
  8. heinerlamprecht

    heinerlamprecht New Member

    Yes, I have them. But when I look at the output of "postconf -n", I do not see the entry for the virtual_maps. Now, I understand, why postfix ignores the new settings. But what am I supposed to do now?
     
  9. heinerlamprecht

    heinerlamprecht New Member

    I made a big step forward: First of all, I added a line in the main.cf for using virtual_alias_maps instead of virtual_maps. Secondly, I noticed a warning of postfix, when he is restarted by ISPConfig. He complains about a missing /etc/postfix/virtusertable.db file. But when I call

    Code:
    postmap virtusertable
    afterwards, the mail gets through.

    Is this problem known? Is there something to do against it? I cannot do this manually after each change and I don't want to make a cronjob for this.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no known problem with this in ISPConfig. ISPConfig calls the postmap script automatically avter every change in the virtusertable file.

    Please have a look at the file /home/admispconfig/ispconfig/ispconfig.log for errors. Or another script on your server or another controlpanel like webmin has removed the virtusertable.db file.
     

Share This Page