Can no longer ftp or sftp to many sites

Discussion in 'General' started by PermaNoob, Mar 18, 2008.

  1. PermaNoob

    PermaNoob Member

    Without changing anything, I can no longer ftp or sftp to many of my sites.

    On one, I couldn't ftp to it so I added shell acess and could sftp to it, but now I can do neither.

    I've tried adding shell access to others but still can't sftp to them.

    One error I'm getting is: Cannot initialize SFTP protocol. Is the host running a SFTP server?

    FTP and SFTP still works on some sites.

    I've restarted the ftp service and rebooted the server--it doesn't help.

    Web-ftp works fine.

    I've also tried different ftp programs (I normally use winscp) but that doesn't help either.

    One connection timed out after a few seconds--could the time-out have been screwed up somehow?

    I haven't made any changes or updates to the server when this started happening. I'll probably update to 2.2.21 soon (I have 2.2.9 now) -- would that most likely solve the problem?
    Last edited: Mar 18, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Your problem is most likely not related to ISPConfig. So updating ISPConfig will not solve it because you are still able to login with WebFTP, so the account configuration is fine.

    Do you use a firewall on the server or on your desktop?
  3. PermaNoob

    PermaNoob Member

    This came to my attention because clients couldn't ftp to their sites, so I don't think it's on my end.

    I can connect by sftp, but I can't enable sftp on a site and get it to work.

    Recently I could still ftp to some sites, but now I can't find a site I can ftp to.

    Side issue but maybe connected--I was trying to backup sites, but even if I just select 10 sites it fails before it times out--ftp'ing them to a 2nd drive at the server.
  4. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    netstat -tap
    iptables -L
    Have you tried both active and passive transfers in your FTP client?
  5. PermaNoob

    PermaNoob Member

    Till's expert update of ISPconfig and my debian etch installation fixed it--well worth the money to insure I didn't screw up something and cause down time--(not to mention the hours I would have had to spend preparing before attempting it myself)--the loss of one customer would have cost many times as much, and avoiding the stress is priceless:D

Share This Page