Can log into website using filezilla but not browser

Discussion in 'General' started by adamjedgar, Sep 12, 2017.

  1. adamjedgar

    adamjedgar Member

    Jsut when i thought my ftp issues were over i have struck upon another.

    I have configured the server to use Explicit FTP over TLS and can successfully browse, upload and delete files in client1/web1 director when logged in as client ftp account.

    However, now i need to be able to use in browser editing, which i believe utilises scripts (such as php) that Adobe Muse also publishes with its websites.

    I continue to get an error when attempting to log in using Adobe in browser editing

    The username and password are invalid for your FTP server. Please check them and try again.
    Server Message: 530 Login authentication failed

    My login details are exactly the same as the ones that work with this user in uploading the files from adobe muse (or filezilla) in the first place. It just doesnt work with web browser???

    In Adobe FAQ's

    Why am I getting an error after entering my username and password?
    If you're sure you are using the correct credentials, other possible causes for errors while logging in are that your FTP server isn't accessible from the public Internet, or that connections are restricted by IP address. Check with your ISP to ensure that your FTP server is accessible from any address.
    If connections are restricted by IP address, you can allow access from the following addresses: 54.187.232.89, 54.191.78.75, 52.5.99.105, 52.5.99.102, 52.17.136.25, 52.17.112.74.
    These IPs are static and should not change in the future.

    What protocol does In-Browser Editing use to connect to my server?
    In-Browser Editing connects to your server using the same protocol used to publish your site from Muse. So, if you published using SFTP, In-Browser Editing will as well. The web editor communicates with the In-Browser Editing server via an encrypted connection. We temporarily store your credentials, in encrypted form, for up to 60 minutes or whenever your session is over.



    in reading FAQ's from Adobe, if i am able to publish the website then i should be able to edit it as it uses the same protocol. My thoughts are that perhaps this has something to do with php? What needs to be configured in order for a client to be able to login to their website using a browser?

    Ah, i have finally found what i think may be confirmation of my php concern. After publishing an update to the site from adobe muse itself (not in browser editing) i see the following error...

    PHP is not configured correctly on your web server. Muse forms will not work correctly unless PHP is enabled on the web server. Contact your hosting provider or website administrator about how to enable PHP support.

    i checked my other vestacp server...it is running php 5. perhaps this is why Adobe muse in browser editing isnt working?

    hmmm thats strange...when i create an info.php file and upload it to the webserver, browsing to it does not return php info. Instead i just get the actual code in the info.php file i create displayed on the screen???

    I followed the perfect server setup...how is it that php isnt working? Is it not installed? now i am really confused.
    Also, yesterday i updated my repository and packages list. Today the packages list is completely blank and i cannot update the list (the repository was set to inactive as well). Activating the repository has not fixed this issue. What is going on with this???
     
    Last edited: Sep 12, 2017
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you enable php mode php-fcgi or php-fpm in the website settings with suexec enabled and did you create the phpinfo() file in correct syntax? Current PHP versions require long syntax "<?php" and not "<?" if you did not switch PHP explicitly to old style compatibility mode, so the phpinfo file content has to be:

    Code:
    <?php
    phpinfo();
    ?>
     
  3. adamjedgar

    adamjedgar Member

    my info.php was correct as you had written.

    after a bit of google searching i decided that perhaps im better off not going to debian 9 as i was likely to run into problems with any software that is not compatible with the latest setup (i dont trust adobe muse developers enough) i deleted the server instance and started again using debian 8 instead of 9.

    After running through the perfect server setup for debian 8, then auto installing using standard mode...here we go again the same problem i had before ...pasv mode refuses to work (only this time all of the things i used to sort it with debian 9 did not resolve the issue...the server refusing to accept my client sending its local lan ip address (instead of my home static one). I simply cannot get a reliable method of sorting this problem.

    To add to my woes, the apps package list...which i had working perfectly yesterday, is non functional today (i cant even update it...nothing happens). How does this happen to a server that has been sitting idle all nite?

    I am wondering if i should change to Ubuntu instead of Debian...or maybe even move over to Centos? I have wasted so much time in going through the perfect server setup...then using the automated and manual install methods...surely there has to be a better way that works? one cannot spend 3 or 4 hours going through this arduous process only to strike problems like this and have to start again when something really bad happens.
    Till, which OS have you found is least problematic to get up and running?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The Debian 9 perfect server setup was absolutely fine, no need for a reinstall and the same is with the Debian 8 perfect setup. And if you want to use an older PHP version beside the current ones, then simply install it as additional PHP version. The FTP problems that you have are caused by your router and not by ISPConfig nor the perfect server setup. Your router or firewall blocks the passive FTP requests, that's all. To work around the limitation of your router, you'll have to set the passive IP in pure-ftpd and a passive port range and then open the same port range in your router. But that's the same on any OS (Debian, Ubuntu or CentOS) and it does not matter if you have ISPConfig installed on that system for this as ISPConfig is not involved here.

    Debian 8 or 9, the version does not matter as both work out of the box. The perfect server setup are tested regulraly by simply copy/paste of the commands and the resulting setup always works. But they are made for real hosting systems or vservers located in a datacenter. Your system seems to be at home or in your office behind a router and in such cases, service access limitations applied by your router can happen and the way to work around this for FTP has been described and used by you already.

    Never seen that on any ISPConfig system. It might be that your router blocks the outgoing requests from your server.
     
  5. adamjedgar

    adamjedgar Member

    Ok i will try that.

    I am finding that passive transfer mode is what is causing all my problems....active works perfectly everytime.

    Which ip address am i supposed to enter...my desktop pc one?

    My confusion on these tutorials relates to their use of ip addresses. Using 192.x.x.x for example...what is that, the local internal ip you are using or your public one? (i have set my google cloud instance public ip address (ie 35.189.x.x)

    Also, your perfect server setup doesnt exactly work for google cloud instances in the server preparation part. Google cloud instances appear to only allow an instance to be create with an O/S already on it (so i dont get to go through that part of your tutorial). Also, i am a little confused about the server internal ipaddress...should i reserver a static internal ip address for my google cloud instance? (google cloud has both static internal and static external ip address capability)

    My assumption is that users following this tutorial on a google cloud deployment should reserve a static internal and static external ip address before starting. I am wondering if me not having done the static internal ip address is likely to cause problems down the track?
    For those who are not familiar with setting up google cloud instances, it appears that a static internal ip address has to be reserved before the vm instance has been created (the ip is assigned during creation). I have already passed this stage before i realised this...so fingers crossed it doesnt become a problem later.


    Could you change the wording so i know which ip i am supposed to be inputting into my hosts file. At present i am reading it as meaning i should substitute my public static external ip? (am i meant to use a static internal one in my hosts file? is this why PASV mode with ftp or sftp clients is not working properly?)

    Also,when you talk my router blocking my server....what router and server are you referring to? My server is a google cloud instance its not a physical system but a virtual one...my router is on a static ip address at my home that my desktop pc and other devices on my home network access the internet through (so my google cloud instance and home router are at opposite ends of the handshake).

    I will start over again today

    EDIT...

    I expected to run into problems again...and i have already. It seems that virtual machine images are different from physical server ones...so some of the things in your perfect server tutorial simply do not work.
    Might i suggest that someone actually gets onto Google Cloud (its free for 12 months) setup and image and run through the perfect server setup as it clearly has errors that do not work on google cloud. I have gone through this over and over again...always striking problems.
     
    Last edited: Sep 13, 2017
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The perfect server tutorials do not have a part that described the OS installation, so there are no conflicts with Google cloud here. Please read the tutorial again. It tells you to use a minimal OS as basis and it contans a link that you can use to install it when you stat with a bare server instead of a minimal OS that you got from Google.

    In the hosts file, you configure the hostname and IP of your server. When your server is behind a router (so that you have an internal IP and a external IP), then you configure the internal on there. But that's not ISPConfig specific at all, its the case for any Linux system with or without ISPConfig.


    The perfect server tutorials are all written on virtual machines and all servers that I host are virtual machines, so there are no issues regarding the guides on virtual servers and no changes are required to the guides.

    What you complain about is that you have a problem with a specific VM at Google and not with virtual servers in general. With router and firewall I refer to a device in front of your server that blocks the ports. So your problem is that you did not configure the Google VM (Firewall / Router) in front of your VM correctly to allow FTP connects.

    I installed several ISPConfig servers on Google VM's in the past and I did not had to alter the setup that is described in the perfect server guide. When you use Google VM, then you have to configure the ports that shall be accessible in the Google UI of course. But that's not ISPConfig specific as you always have to open the ports of the services that you want to use when you have a firewall o router in front of a server.

    So, to fix your FTP issue with Google:

    1) Set the passive IP and passive port range in the pure-ftpd config to make yours etup compatible with routers and firewalls in front of your server.
    2) Open the same port range in the Google firewall.

    But maybe you want to contact Florian from ISPConfig business support and ask him to install the server for you instead: https://www.ispconfig.org/get-support/?type=ispconfig He uses the same perfect server setup as basis and you will see than that it works like this.
     
  7. adamjedgar

    adamjedgar Member

    agreed it is specific to google cloud, however, i have already opened appropriate ports...that part works no problems at all on both this install and the vestacp one.

    The problem with the perfect server setup is actually encountered at the start of the O/S install. Your tutorial talks about downloading the O/Z image and going through the disk partition and manual install process (setting up timezones etc etc). I cannot manually install an O/S in google cloud, so this part of the tutorial cannot be used. So in missing this step i cannot be sure what the google cloud deployment is actually giving me compared with what your tutorial wants (that makes it hard for problem solving as i am not sure where to begin in this case...is it the GCE automated OS install or something i have done beyond this point?).
    The other part of the tutorial that is not well explained is related to the google cloud internal network in the hosts file. Google automatically inserts this as part of its metadata at the bottom of this file. I missed this and simply added to ip address and new hostname on line 2 (after 127.0.0.* localhost line1). This caused me problems obviously. I have also found, that when i attempt to change this line, google cloud compute changes the line back to reflect its own internal instance metadata if the instance is rebooted....(so i have learned to not change the original google cloud settings in the hosts file without ensuring that google cloud wont simply change it back to default). My current working ISPConfig is the one where i have not altered the hosts file at all (it has been left completely alone as per GCE defaults). The trick is to name the initial GCE instance to your custom hosts name before deploying the initial GCE O/S image!

    i could go on and on and on about the quirks of GCE, but i think the above couple of points is enough to warrant a version of this tutorial specifically for google cloud users. I would do it myself, however, i fear that my inexperience in such things would only serve to make a mess of it! Perhaps i could simply add in things i have done that were needed for me to make this work? (if that is something that is allowed?)

    My current Instance and ISPConfig deployment is working very well at present running Debian 8 (not 9...i cannot get 9 working with this as of yet...i keep getting that php error from adobe muse "in browser editing").
    With Debian 8, and GCE, and the automated ISPConfig install for Debian 7/8, with a little basic tweaking to configure pure-ftpd TLS (and also with basic ftp) I am able to use adobe muse publish function with plain ftp quite well, and also Adboe "in browser editing" is working flawlessly. So right now, Adam is one happy camper and loving ISPConfig.

    I still have some more configuration to sort out to completely resolve my ftpes issue with Adobe Muse. This doesnt seem to be working properly in Muse...although explicit ftp over TLS/SSL appears to be working perfectly in filezilla??? (that one is still a mystery to me)

    As mentioned in another post somewhere, whilst some may ask "why dont you just dump this and use Vestacp, as clearly you have vestacp working"? My answer is a simply one...Till and his staff are very hands on. This is a very active forum where people are genuinely interested in helping others out. That kind of assistance is worth its weight in gold and for me, makes this product by far my best option (so a big thank you Till, when i am able i will go beyond my purchase of the manual and contribute money to this cause...you do wonderful work.).
     
    Last edited: Sep 15, 2017 at 12:33 PM

Share This Page