Can i upgrade my php version without any risk?

Discussion in 'Installation/Configuration' started by VeeTouine, Aug 12, 2015.

  1. VeeTouine

    VeeTouine New Member

    Hello,

    I'm using ISPConfig version 3.0.4.1 on a debian 6, with php 5.3

    Can i update my php version to 5.4? or even 5.5 or 5.6 without a risk for ispconfig?

    My websites are using some CMS like joomla and prestashop, and i need to upate my php version for the latest version of joomla, and soon prestashop too.

    If there is no apparent risk to upgrade php, does someone knows the commande line ?

    Many thanks.
     
  2. Jesse Norell

    Jesse Norell Active Member

    I can't answer your question as I have no experience with ispconfig version 3.0.4.1, but I can say that current versions of ispconfig certainly work with newer php versions. Eg. I'm running the latest 3.0.5.4p8 on the debian jessie php5 package 5.6.9+dfsg-0+deb8u1. So as a "worst" case, upgrade ispconfig and then php. (I would guess the new features added since your version might make upgrading ispconfig worthwhile in it's own right?)
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Installing a different php version will not break ispconfig but it might break your server. I would never install a other PHP version then the default one of the os as ispconfig supports additional PHP versions, so there is never a need to install a different system php.

    In your case, you should first update Debian to 7 and ispconfig to 3.0.5.4p8 as Debian 6 does not get full update and security patch support anymore. The debian update will cause a update to php 5.4 automatically. If you then need PHP 5.5, 5.6 or php 7, then install it as additional php version:

    http://www.howtoforge.com/how-to-bu...e-and-apcu-for-ispconfig-3-on-debian-7-wheezy
     
  4. VeeTouine

    VeeTouine New Member

    Thank you for your answers.

    Last (and first) time i tried to update my system (not ispconfig), ispconfig didn't work anymore. So i don't really want to upgrade to debian 7 and i'm not an expert on this ;)
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Debian has to be updated first. then you run a ispconfig update and hoose to reconfigure services so ispconfig can update the config files to match the new debian version.
     

Share This Page