Can I install uClibc on my ubuntu5.10?

Discussion in 'Installation/Configuration' started by jack.ma, Dec 19, 2006.

  1. jack.ma

    jack.ma New Member

    Hi,folks
    Can I install uClibc on my ubuntu5.10? You see in my distribution gcc 4.0.2 is here.Why do I have to do so? When I make the busybox 1.3.0 it says

    [email protected]:~/kernel/busybox-1.3.0$ make
    CC applets/applets.o
    applets/applets.c:22:2: error: #warning Static linking against glibc
    produces buggy executables
    applets/applets.c:23:2: error: #warning (glibc does not cope well with ld
    --gc-sections).
    applets/applets.c:24:2: error: #warning See
    sources.redhat.com/bugzilla/show_bug.cgi?id=3400
    applets/applets.c:25:2: error: #warning Note that glibc is utterly
    unsuitable for static linking anyway.
    make[1]: *** [applets/applets.o] Error 1
    make: *** [applets] Error 2

    Someone suggestst that

    glibc has critical bugs that
    make it so programs static-linked against glibc with gc-sections
    option DO NOT WORK. Thus BB has provided an error message for you
    rather than generating a binary that will seriously misbehave under
    many circumstances.

    glibc authors have intentionally not supported static linking for a
    long time. If you want static linking, use a different libc that
    properly supports it.

    So,can I and how to install uClibc ?

    Thanks
    -jack
     
  2. falko

    falko Super Moderator ISPConfig Developer

    uClibc is recommended for Busybox.
    What's the output of
    Code:
    apt-cache search uclibc
    ?
     
  3. jack.ma

    jack.ma New Member

    Hi,falko

    This is the output of apt-cache search uclibc as below

    [email protected]:~$ sudo apt-cache search uclibc
    libuclibc-dev - A small implementation of the C library
    libuclibc0 - A small implementation of the C library
    uclibc-toolchain - A compiler wrapper for uClibc

    So, can I install the uclibc, compile some program against the C library, even use the uclibc-toolchain?

    -jack
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Run
    Code:
    apt-get install libuclibc-dev libuclibc0 uclibc-toolchain
    and try again to build Busybox.
     
  5. jack.ma

    jack.ma New Member

    Hi,falko

    Can I compile C program against uclibc with gcc ? If yes, how can I set the gcc 's options to compile successfully?If not,do I need some uclibc related compiler?

    -Jack
     
    Last edited: Dec 25, 2006
  6. falko

    falko Super Moderator ISPConfig Developer

    I think that Busybox compiles against uclibc automatically.
     

Share This Page