Can anyone help?

Discussion in 'Installation/Configuration' started by spamhub, Dec 19, 2006.

  1. spamhub

    spamhub New Member

    Dear experts,

    Can you help in solving my problem regarding the new created virtual host domains.

    I couldn't get them load at the correct location. I have read over many articles on the net, but still couldn't figure out what's wrong there in my dedicated server.

    Here is what I have did so far:
    1. Created (delegated) two namerservers (ns1.mydomain.com and ns2.mydomain.com) with my domain registra. pointed to two dedicated ip addresses.
    2. Added two eth0:0 and eth0:1 to the network interface
    3. Added reverse DNS entry for ns1 and ns2 in the ISP's control panel
    4. Added A records to mydomain.com through ispconfig so reflected in the pri.mydomain.com file under /etc/bind/
    5. Created new site mydomain2.com but it loads the directory /var/www/apache2-default/

    Any help will be appreciated! Thanks!

    P.S.
    A. Ping the 2 nameservers returns response with no problem
    B. Ping the new added site with no problem too (responded by the right IP which assigned when adding the site in ISPConfig)
     
    Last edited: Dec 19, 2006
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please check your apache2.conf file, if there is a section at the end that includes the file Vhost_ispconfig.conf. Also check if there are vhost sections in Vhost_ispconfig.conf, you will find the file in /etc/apache2/vhosts/ or a similar path depending on your apache version and linux distribution.
     
  3. spamhub

    spamhub New Member

    Hi till,

    First of all, I apologise for the double post.

    I have check the apache2.conf, it does include the Vhosts_ispconfig.conf at the end.

    However, when I check the contents of the file Vhosts_ispconfig.conf, it shows an empty file. However the others files (i.e. Vhosts_ispconfig.conf_DATE_TIME) in the folder vhosts have contents.

    It is so strange. Any hints?

    Thanks you!
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  5. spamhub

    spamhub New Member

    Thank Till.

    Here is the result of httpd -t:
    ---------------
    Syntax error on line 58 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
    Invalid command 'php_admin_flag', perhaps mis-spelled or defined by a module not included in the server configuration
    ---------------

    And line 58 of the file is:
    ---------------
    php_admin_flag safe_mode On
    ---------------

    Any suggestion? Sorry I am totally new to this stuff.

    Cheers,
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    This error occors when mod_php is not installed or not loaded on your server. Did you follow one of the perfect setup guides?
     
  7. spamhub

    spamhub New Member

    Yes I have followed "The perfect Setup of Debian 3.1".

    Can I use "apt-get install php-mod" to install it?
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please execute this command to install mod_php and the othet php modules:

    Code:
     apt-get install libapache2-mod-php4 libapache2-mod-perl2 php4 php4-cli php4-common php4-curl php4-dev php4-domxml php4-gd php4-imap php4-ldap php4-mcal php4-mhash php4-mysql php4-odbc php4-pear php4-xslt curl libwww-perl imagemagick
     
  9. spamhub

    spamhub New Member

    Yes I did this before, and get the message as below. Problem exist.
    -----------------
    0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
    -----------------

    Any Idea?
     
  10. martinfst

    martinfst New Member Moderator HowtoForge Supporter ISPConfig Developer

    Which packages did not upgrade? Aka what's the output?
     
  11. spamhub

    spamhub New Member

    Here is the full output:
    --------------
    Reading Package Lists... Done
    Building Dependency Tree... Done
    libapache2-mod-php4 is already the newest version.
    libapache2-mod-perl2 is already the newest version.
    php4 is already the newest version.
    php4-cli is already the newest version.
    php4-common is already the newest version.
    php4-curl is already the newest version.
    php4-dev is already the newest version.
    php4-domxml is already the newest version.
    php4-gd is already the newest version.
    php4-imap is already the newest version.
    php4-ldap is already the newest version.
    php4-mcal is already the newest version.
    php4-mhash is already the newest version.
    php4-mysql is already the newest version.
    php4-odbc is already the newest version.
    php4-pear is already the newest version.
    php4-xslt is already the newest version.
    curl is already the newest version.
    libwww-perl is already the newest version.
    imagemagick is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
    -----------------

    Thanks! Any suggestions?
     
  12. spamhub

    spamhub New Member

    This is the output of the command "httpd -l"
    -------------------
    core.c
    mod_access.c
    mod_auth.c
    mod_log_config.c
    mod_logio.c
    mod_env.c
    mod_setenvif.c
    prefork.c
    http_core.c
    mod_mime.c
    mod_status.c
    mod_autoindex.c
    mod_negotiation.c
    mod_dir.c
    mod_alias.c
    mod_so.c
    ------------------
    mod-php is not load with apache2? How can i do to have it load with apache2?

    Some more hints will be helpful, like what else I should make it to load with apache2...

    Thanks guys for helping me!
     
  13. spamhub

    spamhub New Member

    I've found that the two files (s link - php4.conf and php4.load) are missing under the folder /etc/apache2/mods-enable/ by some unknown reasons.

    After creating the links by ln -s, and restarted apache2, problem seems solved.

    Thanks for you guys again for kindness. Any other opinions regarding making the hosting platform better are still welcome.
     

Share This Page