Can add a site, but the www files are not accessed

Discussion in 'Installation/Configuration' started by badran, Apr 20, 2008.

  1. badran

    badran New Member

    I can add a site by using ispconfig, the skeleton files are added. But when I change the files inside of the \var\www\...\www\ folder that is relevant to that site, they do not change. What could be the problem?

    CentOS 5.1, used the tutorial on this site to set everything up.

    btw the 1st site that was added is working, it is just that I cannot add any other website.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that you enabled the administrator checkbox for the user that you used to upload the files. Otherwise the files get uploaded to the wrong folder.
  3. badran

    badran New Member

    The files are being uploaded to the correct location. But still not working when I go to that address sub-domain it does not resolve to the correct location.

    The server just serves the files that are in /var/www/sharedip.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If you see the files from the sharedIP pagem then you have selected the wrong IP address for the site.

    The IP address that you select in ISPConfig must match the IP address of the DNS A-Record that you created for the subdomain. Only if your server is behind a router, you will have to use the internal IP address, were you forwarded port 80 to from your router.
  5. badran

    badran New Member

    Thanks that solved it.

Share This Page